little help - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

Reply
 
LinkBack Thread Tools
post #1 of 38 Old 04-08-2016, 04:17 PM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 425
 
little help

seems like every other time i take the car out i smell coolent i did get it changed out about 2 months ago...i see no white smoke now.. i did when the shop changed it out and i drove home but not anymore just the smell.. i did see today that the cap was not tighed 100 percent i was able to turn it a little more and now its 100 percent tight.. could this cause the issue and why its only sometimei smell coolent sometimes
Silver bullet is offline  
Sponsored Links
Advertisement
 
post #2 of 38 Old 04-09-2016, 04:55 AM
Premium Member
 
Join Date: Jul 2013
Location: Chicagoland
Posts: 127
 
If whoever did the change is like me he would have overfilled it a bit. I think it's better to let it piss a little out to reach max just in case there is an air bubble or two that burp and leaves it low.

Unless you see a puddle under the car, or it continues for more than a week or two, I wouldn't worry.

Which cap could you find to tighten?

2011 1SS/RS LS3 Cyber Gray Metallic
Comrando is offline  
post #3 of 38 Old 04-09-2016, 07:13 AM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 425
 
talking about the radiator cap i was able to turn it a little bit more.. i did change out the coolent more then a month ago but only drive the car 2 times.. i am thinking also it could be that the spilled and its not all dryed up yet..again i see no white smoke anymore i did when i left the shop after the coolent change.. i think i am going to let it run with the heat on for 20 minuts i would have to think if i see or dont smell anything i should be fine
Silver bullet is offline  
 
post #4 of 38 Old 04-09-2016, 10:25 AM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 425
 
well today i let the car run in storge for 25 minutes with the heat on full blast.. seen no smoke did not smell anything. check the exhaust and seen normal condescension it did not smell like coolent. 4 pack gauges all looked normal.the car temp was reading 186 and i heard the fans kicking in and out.. all the carpet was dry.. i would have to think if there was a issues i would have seen something.....
Silver bullet is offline  
post #5 of 38 Old 04-09-2016, 04:22 PM
Premium Member
 
Join Date: Jul 2013
Location: Chicagoland
Posts: 127
 
Oh good! It could have been just some spillage eventually burned off.

Have you checked the dipstick again?

2011 1SS/RS LS3 Cyber Gray Metallic
Comrando is offline  
post #6 of 38 Old 04-09-2016, 05:30 PM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 425
 
Quote:
Originally Posted by Comrando View Post
Oh good! It could have been just some spillage eventually burned off.

Have you checked the dipstick again?
i check the overflow dip stick the coolent was on the first notch on the bottom. and the coolent in the radiator was sitting right below the
circle in the radiator but this is the car sitting for almost 24 hours.. i think everything will just settles when you let the car sit.. i did not check the oil.. i was just so happy that i did not smell anything coming out of the exhaust.. that would have been a big big issue
Silver bullet is offline  
post #7 of 38 Old 04-09-2016, 07:46 PM
Premium Member
 
Join Date: Jul 2013
Location: Chicagoland
Posts: 127
 
Make sure you fill the overflow to the top mark.

2011 1SS/RS LS3 Cyber Gray Metallic
Comrando is offline  
post #8 of 38 Old 04-25-2016, 05:13 AM
Junior Member
 
1KillerSS's Avatar
 
Join Date: Apr 2016
Location: Toledo, Ohio
Posts: 22
 
Try this. Jack up the front end of your car top it off with fluid turn on your heat and let it run with the cars front end up high. Start this when the car is cold so you can remove your cap and top it off as it warms up.

What concerns me is the white smoke you keep talking about. My mind tells me the shop got an air pocket in the system and overheated your car blowing a head gasket.

But I always think the worst things... Check your engine oil to see what color it is though.


Sent from my iPhone using Tapatalk

Forged bottom end. AGP TT, Dual nozzle meth, ID850's, Livernois dual fuel pumps, ECS BAP, 25% UDP, 3 inch Magnaflow catback with X pipe, Mantic 9000 clutch, DSS 1000hp axles, DSS aluminum driveshaft, ZL1 rear end, solid subframe bushings, HE differential offset bushings, BMR Trailing arm, BMR toe rods, Lingenfelter LNC-2000,SJM Line Lock, and much more Built by, FSP, myself, and some a few others, Tuned by FSP and me 800ish whp
1KillerSS is offline  
post #9 of 38 Old 04-25-2016, 02:14 PM Thread Starter
Member
 
Join Date: Nov 2011
Posts: 425
 
have not seen white smoke anymore. it was that one time after i changed out the coolent... i also put a piece of cardboard under the car and have not seen any leaks at all... also driver side rug feels dry.. i am stared to think the coolent will smell untill its 100 percent burns off... seems like now it will smell only on the driver side now a little. i know a long time ago i sprayed degreaser under the hood and it smoked after the car got hot and it smelled thought the vents and under the hood and each time i drive the car it got less and less untill it was 100 percent gone...again no leaks on the cardboard rug is dry no smell coming out the exguest.. and dont smell anything inside the car... one last thing if i smell the radtior cap after i shut the car down i can smell coolent but no leaks at all by the cap... thanks for your help

Last edited by Silver bullet; 04-25-2016 at 02:17 PM.
Silver bullet is offline  
post #10 of 38 Old 04-25-2016, 04:42 PM
Premium Member
 
Join Date: Jul 2013
Location: Chicagoland
Posts: 127
 
People often confuse steam and smoke. Steam will evaporate, smoke will dissipate but won't evaporate. Coolant will steam, oil will smoke.

Please don't use any of those harsh degreasers. They will eat the paint off your engine and damage plastic parts. Use something like this engine cleaner. Washes off with water.
Attached Thumbnails
Click image for larger version

Name:	10959.jpg
Views:	33
Size:	24.0 KB
ID:	49345  

2011 1SS/RS LS3 Cyber Gray Metallic
Comrando is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome