Camaro L99 Valve lifters problem - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

 
LinkBack Thread Tools
post #1 of 1 Old 05-09-2017, 01:23 PM Thread Starter
Newbie
 
Join Date: May 2017
Posts: 2
 
Unhappy Camaro L99 Valve lifters problem

Hello dear, I would like to ask how to replace the bad valve lifter on the Camaro 2012 L99 8V. I have heard the tickle noise when engine run.. I heave recorded the voice for sure and check. I think it is some broken valve lifter.

You can check here on this link: https://www.dropbox.com/s/xig5haoxq6...amaro.m4a?dl=0

I checked lot of forums and videos but nobody show or explain on the LS99 engine.
This ticking start 2 days ago acutally when was driving the car..

I bought this car year ago from USA, love this car.
Many thanks for help!
Jakub is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome