car leaning towards the drivers side - ModernCamaro.com - 5th Generation Camaro Enthusiasts
4th Generation F-Body 1993-2002 Camaro & Firebird Discussion

 
LinkBack Thread Tools
post #1 of 10 Old 03-10-2009, 11:31 PM Thread Starter
 
Join Date: Feb 2009
Posts: 21
 
car leaning towards the drivers side

I know the problem but figured guys would want to know what symptoms I had... I just brought the car so Im attacking alot of its problems now....anyway... car is leaning toward the drivers side heavily...when I drive, however, I hear thumbing (when hitting bumps) on the passanger side... when installing my corvette C6 rims I took a good look at all springs and shocks(C6 RIMS fit/looked great)... the passanger side front shock was leaking its oil...how odd is it that the drivers side is leaning yet the passanger side shock is shot... Im gonna change the whole suspension Eibach springs with monroe shocks... hopefully that solve it all anyhow
95 z28 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 03-27-2009, 07:17 PM Thread Starter
 
Join Date: Feb 2009
Posts: 21
 
same leaning problem

car was leaning to the driverside...I changed the front shocks/ springs with a lowering kit... however the car is still leaning to the drivers side... why would it still lean if I changed out the whole front suspension.... could it be the rears springs are bad?... I have the rear lowering kit but I like the look of the front end low... if I have to I will change out the rear also... any Ideas
95 z28 is offline  
post #3 of 10 Old 03-27-2009, 07:27 PM
Veteran Member
 
Join Date: May 2008
Location: Windsor
Posts: 4,533
  
Check you alignment and suspension. You probably have bad springs and shocks.

┌∩┐(◣_◢)┌∩┐
Taglane is offline  
 
post #4 of 10 Old 03-27-2009, 10:09 PM
Moderator
 
slims00ls1z28's Avatar
 
Join Date: Nov 2006
Location: TN
Posts: 2,717
 
Got a carfax? has it been wrecked? Did the noise stop over bumps?

2000 Red 1SC Z28 A4 - dead for now
2005 Black GTO M6 6.0 - Split daily driver
1987 Silver Fiero GT - Split daily driver
slims00ls1z28 is offline  
post #5 of 10 Old 03-28-2009, 11:17 AM Thread Starter
 
Join Date: Feb 2009
Posts: 21
 
any solutions

I brought the car for $4K .. So I cant complain... what if I put 2 thick heavy duty metal washers under the coil overs on the drivers side... wouldnt that lift the drivers side up some... thats the best idea I can come up with without taking the suspension apart (pain in my ass)... just about all the hex bolts had to be cut out.. thank god for dermels... I'll post some pic when Im done with the car... it looks good!
95 z28 is offline  
post #6 of 10 Old 03-28-2009, 11:47 AM
MODERATOR
 
54inches's Avatar
 
Join Date: Dec 2006
Location: Dirty Bay, Texas
Posts: 8,984
  
Is this with or without you in the driver's seat?

2005 CTSV BLACK LS7 Clutch/Flywheel/Slave, Tick Speed Bleeder, Tilton Clutch MC, RevShift Bushings, Domestic V8 Solutions (shifter, 8.8 Diff conversion, srut tower braces, sub-frame connectors), SLP cats, no cags, xpipe, bullet mufflers, Volante, iPod dock, G-force tune; 379hp 381tq.

Killing 5th gens like it is my job.
54inches is offline  
post #7 of 10 Old 03-28-2009, 12:25 PM Thread Starter
 
Join Date: Feb 2009
Posts: 21
 
... thats without me in the seat.... with me in the drivers seat I can only imagine how low it gets.... but its not a slight lean... its pretty heavy lean to the driverside
95 z28 is offline  
post #8 of 10 Old 04-03-2009, 08:52 PM Thread Starter
 
Join Date: Feb 2009
Posts: 21
 
I think I got it

after further searching... I noted the car does NOT have a spare tire or jack... thats about 40lbs that was suppose to sit right on the right rear suspension... could that be why the car is leaning???
95 z28 is offline  
post #9 of 10 Old 04-03-2009, 11:12 PM
MODERATOR
 
54inches's Avatar
 
Join Date: Dec 2006
Location: Dirty Bay, Texas
Posts: 8,984
  
No.
54inches is offline  
post #10 of 10 Old 04-03-2009, 11:13 PM
MODERATOR
 
54inches's Avatar
 
Join Date: Dec 2006
Location: Dirty Bay, Texas
Posts: 8,984
  
It's a suspension problem.

Something is broken.

Is it only on the front or only on the rear?
54inches is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome