need help!!! - ModernCamaro.com - 5th Generation Camaro Enthusiasts
4th Generation F-Body 1993-2002 Camaro & Firebird Discussion

 
LinkBack Thread Tools
post #1 of 7 Old 06-29-2008, 08:20 PM Thread Starter
Newbie
 
Join Date: Jun 2008
Posts: 2
 
need help!!!

my 94 camaro rs is makin a clickin noise. i put flowmasters on it and could only get 1 of the 2 bolts back into the cat. it runs fine but i know i have an exaust leak. i put some radiator stop leak in it and the next day the **** thing was makin a clickin noise. it started that morning when i first started it but stoped w/in 15 seconds. so i didnt think anything of it. i drove around all day. and that night when i was goin to run to the store, there was the clickin. i waited and it didnt stop. so i put some sea foam in my oil( thinkin 1 of my valves was stickin) didnt work.
what could be wrong?
i live in plano off 121 and coit, and if someone could come by and look at it and mayb tell me whats wrong or something that would be great.
ilicurtisili is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-29-2008, 08:32 PM
Banned
 
Join Date: Jun 2007
Posts: 4,153
  
I'm sure the o-ring on the cat isn't seated right, therefor causing an exhaust leak. They almost always sound like engine ticking. It's not a big deal. Just annoying.
Devryn is offline  
post #3 of 7 Old 06-29-2008, 08:32 PM
BDC
Senior Member
 
Join Date: Sep 2007
Location: Canton Mi.
Posts: 523
 
if its an automatic try tightening the flywheel bolts (flywheel to trans converter)

just another guy dreaming of owning a 09 camaro

WWW.MYSPACE.COM/BDCNDE
BDC is offline  
 
post #4 of 7 Old 06-29-2008, 08:54 PM Thread Starter
Newbie
 
Join Date: Jun 2008
Posts: 2
 
it sounds like its the motor but idk if its the exaust leak sound goin through the headers
ilicurtisili is offline  
post #5 of 7 Old 07-02-2008, 09:54 AM
ModernCamaro.com Founder / Former Camaro Disciple
 
OctaneZ28's Avatar
 
Join Date: Jan 2006
Location: Chicagoland, IL
Posts: 11,842
           
Definitely sounds like an exhaust leak to me too.
Like Devryn said, it's gotta be at the cat where the bolt isn't in.

2001 Camaro Z28 H/C/I LH6 A4 3.42

Like ModernCamaro.com on Facebook!
OctaneZ28 is offline  
post #6 of 7 Old 07-03-2008, 10:38 PM
Moderator
 
slims00ls1z28's Avatar
 
Join Date: Nov 2006
Location: TN
Posts: 2,717
 
You put radiator stop leak in because of an exhaust leak? Or was there something wrong with the cooling systome to warrant that. Like the two above said the exhaust leak is the cause of your tick.

2000 Red 1SC Z28 A4 - dead for now
2005 Black GTO M6 6.0 - Split daily driver
1987 Silver Fiero GT - Split daily driver
slims00ls1z28 is offline  
post #7 of 7 Old 07-04-2008, 11:07 PM
Veteran Member
 
POWERFREAK's Avatar
 
Join Date: Feb 2008
Location: NY
Posts: 7,873
  
OK, don't laugh, but you DID put the radiator stop leak in your radiator...right?

I saw a thread on a mazda miata board where a "smart" miata owner put radiator stop leak in his engine.


but anyway, yes, it sounds like an exhaust leak.

2010-2SS/RS/LS3/IBM/RP6: ECS-Paxton Supercharger / American Racing Headers & Exhaust / PFADT Suspension / DSS 9" 4.10 Rear / FOR SALE!

Quote:
Originally Posted by Taglane View Post
Powerfreak is the only one who actually understood anything.
POWERFREAK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome