My speedometer stopped working? - ModernCamaro.com - 5th Generation Camaro Enthusiasts
5th Generation Camaro News & General Discussion News Articles & General Discussion about the 5th Generation Camaro.

 
LinkBack Thread Tools
post #1 of 9 Old 07-28-2009, 12:49 AM Thread Starter
Newbie
 
Join Date: Jun 2009
Posts: 2
 
My speedometer stopped working?

Anyone had this problem yet? It quit for about 20 miles, then started working again. Weird?


2010 Camaro LT1
1600 miles
lochneffmonster is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 07-28-2009, 05:51 AM
Senior Member
 
CamaroSS/RS's Avatar
 
Join Date: May 2009
Location: Santa Clarita,CA
Posts: 731
 
what did the needle do did it just not respond also what is your vin supposedly early cars had a gauge problem.i could be wrong take it to the dealer if it does it again

GTFO of here with your ricer math
CamaroSS/RS is offline  
post #3 of 9 Old 07-28-2009, 10:00 AM
Banned
 
Join Date: Oct 2008
Posts: 173
 
I would take it in to the dealer. Thats the beuty of having a warantee
MoranoRacing is offline  
 
post #4 of 9 Old 07-28-2009, 10:46 AM
Junior Member
 
Samrs914's Avatar
 
Join Date: Jul 2008
Posts: 65
 
mine has done this a few times...ill get it to the dealer one of these days
Samrs914 is offline  
post #5 of 9 Old 07-28-2009, 12:50 PM
Member
 
Chuckduck's Avatar
 
Join Date: Jul 2007
Posts: 220
 
The Chevy SSR's had a problem with a high percentage needing the Speedo replaced, my '03 SSR would stick or give a false reading and then work perfectly for awhile until it just quit working.
Chuckduck is offline  
post #6 of 9 Old 07-28-2009, 02:29 PM
Junior Member
 
Hicompression's Avatar
 
Join Date: Jul 2009
Location: DFdubya
Posts: 95
 
Well, if the odometer runs off the speedometer, Chevrolet will have a lot of low mileage used cars to compete with new car sales in a couple of years.

2010 RY 2SS 6M
Hicompression is offline  
post #7 of 9 Old 09-22-2011, 04:48 PM
Member
 
ZL1213's Avatar
 
Join Date: Jul 2009
Posts: 356
 
The wife's 2010 did the same thing. I had video of it, but forgot to backup before i replaced my phone. It has happened twice.

ZL1213 (formerly Z OHHH 6)


2010 2SS/RS (Auto/L99)
2012 ZL1 #213 - M6, Black on Black
ZL1213 is offline  
post #8 of 9 Old 09-22-2011, 05:29 PM
Veteran Member
 
hypurone's Avatar
 
Join Date: Aug 2009
Location: Cali. North Bay
Posts: 1,925
 
Garage
Haven't read anything about gauges being replaced but have read about the speed sensor being replaced quite a few times....

Chuck
2010 SIM 2SS/RS A6 SC - Born on 10/05/09
MyCamaroBuildInfo

"You Were Really Flyin' When I Passed You Back There!"
February-2013-MOTM-Winner
hypurone is offline  
post #9 of 9 Old 09-22-2011, 06:04 PM
Bully Proof
 
Envy's Avatar
 
Join Date: Apr 2010
Location: Dallas, TX
Posts: 7,086
  
Garage
This thread is over two years old so I'm guessin' this isn't a common problem but here's my .02.

If the speed sensor quits working...you should get a CEL. I just replaced one on my niece's Jeep Liberty this weekend and once the speedometer stopped working a CEL was thrown indicating a speed sensor malfunction.
Envy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome