Clicking sound - ModernCamaro.com - 5th Generation Camaro Enthusiasts
5th Generation Camaro News & General Discussion News Articles & General Discussion about the 5th Generation Camaro.

Reply
 
LinkBack Thread Tools
post #1 of 13 Old 10-17-2009, 06:58 PM Thread Starter
Member
 
Warlock's Avatar
 
Join Date: Jul 2009
Location: Texas
Posts: 359
 
Clicking sound

Just got my Camaro today. I did notice a clicking sound coming from where the engine oil dipstick is when the engine is running. Anyone has experienced this? Should I worry? It is not loud, but it's constant, click, click, click...

Thanks.
Warlock is offline  
Sponsored Links
Advertisement
 
post #2 of 13 Old 10-17-2009, 09:22 PM
Member
 
LS3-2SS's Avatar
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 175
 
Well that's weird. You have that too? Mine only clicks about three times and then goes away.

2SS/RS, M6, Silver Ice, Black leather, 20" polished wheels
LS3-2SS is offline  
post #3 of 13 Old 10-18-2009, 11:38 AM Thread Starter
Member
 
Warlock's Avatar
 
Join Date: Jul 2009
Location: Texas
Posts: 359
 
Quote:
Originally Posted by LS3-2SS View Post
Well that's weird. You have that too? Mine only clicks about three times and then goes away.
I started it this morning and accelerated it a bit and the clicking noise became faster. I accelerated more and the clicking noise turned like into a "rattling noise". I'm worried. Anyone else has run into this? Hopefully I'm over reacting. The car has 60 miles on it. Advice please!

Thanks.
Warlock is offline  
 
post #4 of 13 Old 10-18-2009, 11:42 AM
Veteran Member
 
Luwinkle's Avatar
 
Join Date: Jul 2007
Location: Louisville, KY
Posts: 10,420
 
Take it to the dealer.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Quote:
Originally Posted by Jeremy Clarkson
A turbo, exhaust gasses go into the turbocharger and spin it, with a supercharger, air goes in, witchcraft happens and you go faster.
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
Luwinkle is offline  
post #5 of 13 Old 10-18-2009, 11:43 AM
Veteran Member
 
JoSSh's Avatar
 
Join Date: Aug 2009
Location: Cincinnati, Ohio
Posts: 1,109
 
I haven't heard anything about this yet. Did you pull the dipstick out and put it back?


Rally Yellow 2SS/RS
Fifty years from now, when you're looking back at your life, don't you want to be able to say you had the guts to get in the car?
JoSSh is offline  
post #6 of 13 Old 10-18-2009, 12:00 PM Thread Starter
Member
 
Warlock's Avatar
 
Join Date: Jul 2009
Location: Texas
Posts: 359
 
Quote:
Originally Posted by JoSSh View Post
I haven't heard anything about this yet. Did you pull the dipstick out and put it back?
Yes. That was the first thing that I thought about. Not sure what to do other than calling the dealer. The noise is faint but loud enough that you can hear it. What really worries me is that the clicking noise gets faster when accelerating, isn't that engine related?
Warlock is offline  
post #7 of 13 Old 10-18-2009, 12:11 PM
Member
 
LS3-2SS's Avatar
 
Join Date: Jul 2009
Location: Lubbock, TX
Posts: 175
 
Quote:
Originally Posted by Warlock View Post
Yes. That was the first thing that I thought about. Not sure what to do other than calling the dealer. The noise is faint but loud enough that you can hear it. What really worries me is that the clicking noise gets faster when accelerating, isn't that engine related?
Probably. Best take it in an have the dealer check it. Mine has 55 miles on it. Hope I don't have to go in too.

Mine sounds like it could be electrical, like relays or switches opening and closing.

2SS/RS, M6, Silver Ice, Black leather, 20" polished wheels

Last edited by LS3-2SS; 10-18-2009 at 12:19 PM.
LS3-2SS is offline  
post #8 of 13 Old 10-18-2009, 12:48 PM
Member
 
Join Date: Oct 2008
Posts: 472
 
Quote:
Originally Posted by Warlock View Post
I started it this morning and accelerated it a bit and the clicking noise became faster. I accelerated more and the clicking noise turned like into a "rattling noise". I'm worried. Anyone else has run into this? Hopefully I'm over reacting. The car has 60 miles on it. Advice please!

Thanks.


AC Compressor?

You gotta see Jack.
Fourth Camaro is offline  
post #9 of 13 Old 10-18-2009, 01:51 PM
Newbie
 
Join Date: Jul 2009
Posts: 1
 
it has to do with the ignition with the throttle my cobalt ss/sc and saturn sky both do the same thing
bigd2114 is offline  
post #10 of 13 Old 10-18-2009, 02:09 PM
zen
Junior Member
 
Join Date: Jun 2009
Posts: 43
 
On a previuos post it was stated that it has to do with the Gasoline venting and purging system.
zen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome