Did a coast run for lunch... - ModernCamaro.com - 5th Generation Camaro Enthusiasts
5th Generation Camaro Pictures, Videos & Photoshops Post your Camaro pictures, videos and photoshops here!

 
LinkBack Thread Tools
post #1 of 2 Old 11-24-2010, 06:32 PM Thread Starter
Veteran Member
 
hypurone's Avatar
 
Join Date: Aug 2009
Location: Cali. North Bay
Posts: 1,925
 
Garage
Did a coast run for lunch...

Had an awesome midweek run to the coast for lunch and some all around general shennanigans... Still managed to have my fav sections of the coast road blocked by one or two f*cktards tho.

Oh well, at least I was out driving!

At our last stop:


Chuck
2010 SIM 2SS/RS A6 SC - Born on 10/05/09
MyCamaroBuildInfo

"You Were Really Flyin' When I Passed You Back There!"
February-2013-MOTM-Winner
hypurone is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 11-24-2010, 07:44 PM
sdk
Veteran Member
 
Join Date: Sep 2009
Location: South Carolina
Posts: 4,977
 
Garage
Driving is so much more fun with a Camaro! How do Camry, Accord, etc. owners tolerate driving?


2017 Camaro SS
South Carolina
sdk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome