'Check Engine Light' On - ModernCamaro.com - 5th Generation Camaro Enthusiasts
Diagnostics & Tuning Diagnostics | Programming | Tuning

Reply
 
LinkBack Thread Tools
post #1 of 23 Old 09-06-2009, 02:25 PM Thread Starter
Member
 
Steve@Subthump's Avatar
 
Join Date: Jan 2009
Location: Indiana
Posts: 104
 
'Check Engine Light' On

So I installed my LMR CAI and SLP Loudmouth on Friday. Great combination, btw. Drove the car two days, love it, not problems. Now today, I start up and leave for a car show and my engine light comes on and stays on. Anyone have any ideas? I was under the impression that these kits would not do this. I just want the light off cuz I'm concerned a bit and it really bugs me, yet I don't want to take it all the way back to the dealer to clear out a code or whatever.
Sponsored Links
Advertisement
 
post #2 of 23 Old 09-06-2009, 02:52 PM
Junior Member
 
Join Date: Jun 2009
Posts: 75
 
Drive it for 100 plus miles, it may go out.
surfgun is offline  
post #3 of 23 Old 09-06-2009, 02:53 PM
Veteran Member
 
bamaproshop's Avatar
 
Join Date: Oct 2008
Location: Wetumpka, Alabama
Posts: 8,645
  
Garage
Might have to disconnect battery and leave it for about an hour then reconnect.

2014 2LT/RS with spring edition package. Proud Litho Owner #28.
bamaproshop is offline  
 
post #4 of 23 Old 09-06-2009, 03:56 PM Thread Starter
Member
 
Steve@Subthump's Avatar
 
Join Date: Jan 2009
Location: Indiana
Posts: 104
 
Quote:
Originally Posted by bamaproshop View Post
Might have to disconnect battery and leave it for about an hour then reconnect.
I'll try that. The manual says to run a few tanks of gas thru it and it may go out. Don't really want to wait that long though.
post #5 of 23 Old 09-06-2009, 04:16 PM
Veteran Member
 
urbanlegend's Avatar
 
Join Date: Jul 2007
Location: Virgina Beach
Posts: 1,039
 
Quote:
Originally Posted by [email protected] View Post
I'll try that. The manual says to run a few tanks of gas thru it and it may go out. Don't really want to wait that long though.
Holy crud! A manual says that?! (I don't have a Camaro yet so yes I'm clueless) God bless America. The imports all say if it stays on, take it to a dealer. Which translates to "If it stays on, bring it to us so that we can charge you for an hour of garage time to diagnose it and then an arm and a leg to "fix" it."

Crap on toast I can't wait to get a dang Camaro.

Still a wannabe.
urbanlegend is offline  
post #6 of 23 Old 09-06-2009, 04:21 PM
Veteran Member
 
SSRS's Avatar
 
Join Date: Apr 2009
Location: California
Posts: 2,157
 
ermm.... you guys realize that the if the light is on.. you should probably CHECK the engine... idk.. that's just me

SSRS is offline  
post #7 of 23 Old 09-06-2009, 04:42 PM
Junior Member
 
Join Date: Jun 2009
Posts: 75
 
He put a CAI and his check engine light came on. Oh my, run for the hills the sky is falling, must get to dealer to check the dreaded light. Please.
surfgun is offline  
post #8 of 23 Old 09-06-2009, 05:02 PM
Member
 
firestone_ss's Avatar
 
Join Date: Mar 2009
Location: Tacoma WA
Posts: 114
 
or he left the gas cap loose
firestone_ss is offline  
post #9 of 23 Old 09-06-2009, 06:48 PM Thread Starter
Member
 
Steve@Subthump's Avatar
 
Join Date: Jan 2009
Location: Indiana
Posts: 104
 
Quote:
Originally Posted by firestone_ss View Post
or he left the gas cap loose

Def. not the gas cap as I have not filled up since installing those parts. Like surfgun says, I'm not freaking out and wanting to rush it right over to the dealer. It's actually a major hassle to drive it to the dealer. And I really don't want them to see those parts. I just wanted to see if anyone else has had this occur. I know **** well it's some code due to those aftermarkets being installed and not some major issue. Car only has 400 miles on it and I have been under the hood more than in the driver's seat. Not sure what you mean when you say I should 'check' the engine because what's to check. Seriously. It's not like oil is spewing out or things are coming loose.

Last edited by [email protected]; 09-06-2009 at 08:03 PM.
post #10 of 23 Old 09-06-2009, 07:54 PM
Veteran Member
 
TX_SS's Avatar
 
Join Date: Feb 2009
Location: San Antonio, TX
Posts: 2,794
 
Quote:
Originally Posted by [email protected] View Post
Def. not the gas cap as I have not filled up since installing those parts. Like surfgun says, I'm not freaking out and wanting to rush it right over to the dealer. It's actually a major hassle to drive it to the dealer. And I really don't want them to see those parts. I'd just wanted to see if anyone else has had this occur. I know **** well it's some code due to those aftermarkets being installed and not some major issue. Car only has 400 miles on it and I have been under the hood more than in the driver's seat. Not sure what you mean when you say I should 'check' the engine because what's to check. Seriously. It's not like oil is spewing out or things are coming loose.
FWIW, I installed my LMR CAI about 3 weeks ago, after installing Corsa cat-backs, no lights so far. I invested a little change a few years ago to get an Innova Scan Tool, so I could read ODB2 codes and clear them if needed. If you don't have a scanner, take it to any half way reputable shop and they should be able to clear it for ya in a couple minutes.

2SS/RS, CGM, A6, Magnuson TVS2300 Supercharger
My latest dyno: http://www.youtube.com/watch?v=XjrLR0N12B4
TX_SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome