2013 Frameless Mirror install in 2010 Camaro - ModernCamaro.com - 5th Generation Camaro Enthusiasts
Do-It-Yourself and How-To Write-ups Show us how it's done! Post your DIY and HOW-TO write ups here!

Reply
 
LinkBack Thread Tools
post #1 of 15 Old 04-14-2013, 05:00 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
2013 Frameless Mirror install in 2010 Camaro

This is a little more than just plug and play. You need to hook up two wires to the mirror. The method I used does it in a manner that no factory wiring is cut. I hope you have good eyes.

Tools needed
Frameless Mirror 13580912
T20 Torx Bit
Jewelers screw drivers
Wire strippers
2 pieces of wire about 12 feet in length (ideally red and light green)
Electrical tape
Scissors (to cut electrical tape)
Zip ties, or twist ties


Old Mirror


New Mirror

Last edited by skuttduck; 04-14-2013 at 05:12 AM.
skuttduck is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 04-14-2013, 05:11 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
Get the new mirror, remove the plastic piece and then remove two pins from the new mirror. The red and the green pins.



Using the jewelers screw driver press on the sides of the white retaining clip to pop the clip up.




Next use the jewelers screw driver to pry up the plastic tabs on the green and red pins to remove them.





Put the white retaining clip back in.
skuttduck is offline  
post #3 of 15 Old 04-14-2013, 05:21 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
To run the wires to the mirror, I ran them from the center console. It has the right power wire so that the mirror acts like the previous mirror, as well as the data wire needed. Not only that they are right next to one another.

Pull up on center console.


Slide your hands forward to continue to release clips.


Remove center console and unplug it.


You want to run your two wires into the red wire with white stripe, and small green wire.


I did this by removing the purple retaining clip on the factory harness and shoving the wires into the pin holes. To remove the clip you need to slip it out horizontally. Once that is out, lift up on the plastic retaining part from the front part of the clip and push the female pins out.

The purple clip didn't exist on a late model 2010 2SS car without the chicklets. I was able to secure the wires under the plastic retaining clips.





You can then secure the new wires to the factory with a twist tie.

Last edited by skuttduck; 07-23-2013 at 07:06 AM.
skuttduck is offline  
 
post #4 of 15 Old 04-14-2013, 05:28 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
From here I pushed the wires out under the glovebox and toward the passenger side kick panel. (not pictured)

Remove the passenger side dash panel. This one take a lot of force on my car.



Pull on the A pillar trim. You will need to unclip a part to remove it.


The keyhole slot is where it is clipped at and it clips facing the front of the car.

This is the clip, my middle finger is where you have to unsnap it from.


Here is the A pillar without the trim, showing the factory wiring, sunroof drain and the airbag.
skuttduck is offline  
post #5 of 15 Old 04-14-2013, 05:34 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
Route the wires out the passenger side dash panel.


Remove the outer piece of trim on the old mirror. It snaps tightly on both sides and hooks into the head liner.


Use the T20 Torx bit to remove the screw on the old mirror and remove it from windshield.


Remove the remaining piece of trim from the old mirror. You need them both for the new mirror.
skuttduck is offline  
post #6 of 15 Old 04-14-2013, 05:41 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
Run the wires up the A pillar and along the headliner to the factory wiring.





Slide the new mirror into place. Be sure you put the plastic that holds the plug back on it.


Plug back in the factory plug, and attach the two wires with tape, or your method of choosing. I since changed the install slightly.




There isn't a lot of room here so I ran each wire along each side of the factory plug and tried my best to snap in the trim.- Old method

After not liking the my mirror was "taped" I decided to see if I could find a method that I could retain using the pins on the mirror. If you have old junk PC parts laying around, I did it using an old CD Rom audio cable hookup.

I soldered in and taped up the CD rom audio cable to the two wires that run up the head liner.



I used two of the 4 holes one on each end.

I pulled the other part of the audio cable off of an old motherboard, shoved that into the connector, and taped up the remaining part of the cables.



Behind the factory connector is the CD audio connector, and I just plug the wires in now.




I verifed my onstar worked by using the virtual advisor, and when I drove at night the auto dimming worked fine as well.

Last edited by skuttduck; 04-28-2013 at 04:12 PM.
skuttduck is offline  
post #7 of 15 Old 04-14-2013, 08:41 AM
Veteran Member
 
Guapo's Avatar
 
Join Date: May 2009
Location: Crestview Fl
Posts: 2,495
 
Garage
I see you have a whisler there how do you have it wired.

2013 LT2/RS, Crystal Red Metallic, TAZ Jr.
2016 H-D Ultra Classic, Black Fire Purple, (PPE)
2015 H-D Street Glide, Superior Blue. (Old Blue) Traded
2012 Big Horn, RAM, Crew Cab, SLT, Dark Cherry Red Pearl (Betty Boop)
1998 Honda Accord 2d, daily driver.
Guapo is offline  
post #8 of 15 Old 04-14-2013, 08:48 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
Quote:
Originally Posted by Guapo View Post
I see you have a whisler there how do you have it wired.
I ran the power wire in to the fuse box, and plugged into the accessory grille. I used a bolt there for the ground. The laser piece runs up the drivers side a pillar trim to the mirror. The voice module is right there as well. The unit is shoved into the grille above the bowtie on the outside of the car.

I ran the wires through the firewall on the passenger side of the car next to the in cabin air filter.

Here is a video I made for camaro5150. You can see a bit more of it.

skuttduck is offline  
post #9 of 15 Old 04-14-2013, 07:11 PM
Premium Member
 
JWD621's Avatar
 
Join Date: Apr 2010
Location: Hurst, Texas
Posts: 4,348
 
Garage
Thanks for the "how to" with great pictures and descriptions.


2010 2SS/RS A6 L99 Born 09/16/2009 Vin#9146985
ModernCamaro Car of the Month Jan 2013
CAI,Axle back exhaust, V Max Throttle Body
JWD621 is offline  
post #10 of 15 Old 04-15-2013, 08:21 AM Thread Starter
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
You're welcome. Dwalex helped me out on Camaro5 with the wiring hook up. The how to over there wasn't as detailed so I thought once I understood the wiring I would document how to do that.

I still might try and improve the plugin for the pins I removed I'm thinking perhaps I can find something off of an old PC that would work.
skuttduck is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome