Factory Amp - ModernCamaro.com - 5th Generation Camaro Enthusiasts
Electronics & Audio Stereo Components | Lighting | Radars | Alarms

 
LinkBack Thread Tools
post #1 of 8 Old 07-28-2013, 01:45 PM Thread Starter
Junior Member
 
Capital's Avatar
 
Join Date: Jul 2013
Location: Clifton, NJ
Posts: 13
 
Factory Amp

Where is it?!

I must be losing my mind. I've searched all over this forum and it consistently says it's in the trunk, on the driver's side, right behind the tail light. I've even seen the pictures.

Yet when I look for myself, it's not there. What. The. Hell?

Last edited by Capital; 07-28-2013 at 08:38 PM.
Capital is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 07-28-2013, 05:06 PM
Veteran Member
 
83Hokie's Avatar
 
Join Date: Aug 2012
Location: Virginia
Posts: 4,590
 
Did you pull the trunk liner aside? Pretty sure the guidance is correct but you do have to move the liner (i.e. unscrew all the connectors)

2012 2SS / RS CRT; Additional Options: Highwing Spoiler, Sunroof, Window Tint, Splash Guards, Wheels, Nitro, Heritage Grill, MRT Louvers, Ported Throttle Body, Cold Air Inductions CAI, RX Sport Hood, someone's splitter, River City Strut Bar
Born On: 13 April 2012; Purchased: 27 August 2012
83Hokie is offline  
post #3 of 8 Old 07-28-2013, 06:53 PM
Junior Member
 
sycraft's Avatar
 
Join Date: May 2012
Posts: 94
 
I do not think you have one unless it is a BA system
sycraft is offline  
 
post #4 of 8 Old 07-28-2013, 07:23 PM Thread Starter
Junior Member
 
Capital's Avatar
 
Join Date: Jul 2013
Location: Clifton, NJ
Posts: 13
 
Quote:
Originally Posted by sycraft View Post
I do not think you have one unless it is a BA system
Well that would explain it. Any idea where it is otherwise?
Capital is offline  
post #5 of 8 Old 07-28-2013, 07:25 PM
Veteran Member
 
83Hokie's Avatar
 
Join Date: Aug 2012
Location: Virginia
Posts: 4,590
 
I have the BA system, so sorry my answer was based on that.

2012 2SS / RS CRT; Additional Options: Highwing Spoiler, Sunroof, Window Tint, Splash Guards, Wheels, Nitro, Heritage Grill, MRT Louvers, Ported Throttle Body, Cold Air Inductions CAI, RX Sport Hood, someone's splitter, River City Strut Bar
Born On: 13 April 2012; Purchased: 27 August 2012
83Hokie is offline  
post #6 of 8 Old 07-28-2013, 08:10 PM
Junior Member
 
sycraft's Avatar
 
Join Date: May 2012
Posts: 94
 
no BA, no amp...
sycraft is offline  
post #7 of 8 Old 07-28-2013, 08:39 PM Thread Starter
Junior Member
 
Capital's Avatar
 
Join Date: Jul 2013
Location: Clifton, NJ
Posts: 13
 
Quote:
Originally Posted by 83Hokie View Post
I have the BA system, so sorry my answer was based on that.
Understandable. No worries
Capital is offline  
post #8 of 8 Old 07-28-2013, 09:06 PM
Member
 
Poohdogger's Avatar
 
Join Date: Dec 2011
Posts: 158
 
It's true no BA no amp......it's powered by the radio......

Custom installer 25 years in the game............ owner of Voo Doo Customs
Poohdogger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome