MyLink Freezing - ModernCamaro.com - 5th Generation Camaro Enthusiasts
Electronics & Audio Stereo Components | Lighting | Radars | Alarms

 
LinkBack Thread Tools
post #1 of 4 Old 08-17-2017, 04:08 AM Thread Starter
Junior Member
 
nightwing91's Avatar
 
Join Date: Dec 2014
Location: Kentucky
Posts: 12
 
Garage
Question MyLink Freezing

So about 6 months ago I got a notification from Chevy saying my 2013 RS had a software upgrade for the Mylink system and I had to option of making an appointment at a dealer or purchasing the USB myself and upgrading. I went with the latter. Until now I've not had any issues but about a week ago I drove my car to the gym, everything worked fine but when I got back in and connected my Ipod, it was like the mylink was frozen on the home screen. The oddest part was the radio was playing but then slowly faded out. I turned the car off/on several times, opened the door all of that. Nothing worked. Every time I would turn the car on the screen on the mylink would be the same home screen, it wouldn't start up like normal. By the time I got home I turned the car off/on one more time and...it rebooted and worked fine. Yesterday (about 2wks after the first incident) everything was working fine, I stopped for gas, and when I got back in my car the my link wouldn't come on at all. I did the same think as before, drove home and let it sit for about 30mins when I got home and tried starting again and it rebooted and is working fine again.

Have any of you guys had this happen? A friend of mine who is a GM certified mechanic told me I may need to take it into the dealer and have everything reprogrammed...if that's the case do any of you guys know how much that would run me?
nightwing91 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-17-2017, 06:51 AM
Junior Member
 
BlueRaySS's Avatar
 
Join Date: Aug 2017
Posts: 12
 
Garage
there is a bulletin out for bad connections, let see if I can find a number for you.

BlueRaySS is offline  
post #3 of 4 Old 08-17-2017, 07:35 AM
Premium Member
 
JWD621's Avatar
 
Join Date: Apr 2010
Location: Hurst, Texas
Posts: 4,352
 
Garage
That should be a free recall I think.


2010 2SS/RS A6 L99 Born 09/16/2009 Vin#9146985
ModernCamaro Car of the Month Jan 2013
CAI,Axle back exhaust, V Max Throttle Body
JWD621 is offline  
 
post #4 of 4 Old 08-17-2017, 09:19 AM Thread Starter
Junior Member
 
nightwing91's Avatar
 
Join Date: Dec 2014
Location: Kentucky
Posts: 12
 
Garage
Awesome guys, any info about he recall you could give me would be much appreciated. I didn't know there was a possible recall.

I did call the dealer today and they said it would be like ~$80 to reprogram. Which isn't bad but free is always better haha.
nightwing91 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome