Back seat fell during quick deceleration - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

 
LinkBack Thread Tools
post #1 of 4 Old 07-27-2010, 09:12 AM Thread Starter
Member
 
Chuckduck's Avatar
 
Join Date: Jul 2007
Posts: 220
 
Back seat fell during quick deceleration

Had to hit the brakes when another car moved into my lane and the rear seat in my '10 Camaro fell forward hitting the back of my drivers seat hard. I knew the rear seat could be lowered but in the 15 mo. and 18k miles I've owned it I have never tried it and have never notice the two latches being anything but flush. I'm guessing the items in my trunk slid forward hitting the rear seat. Seems like this could be a big issue in an accident with a rear seat passenger. Anyone else have this issue?
Chuckduck is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 07-27-2010, 09:22 AM
Veteran Member
 
cigam21's Avatar
 
Join Date: Apr 2009
Location: Tempe, AZ
Posts: 1,496
 
If you do not see yourself using the pass through and are concerned about it being a hazard, mount it solid. I have had this happen once, but that was from not securing the seat properly. I have the 2 10" speakers back there so objects can not come from the trunk on mine, there is enough space between the seat and the speaker box for my katana & thats about it.

Go to http://www.cheers*****.com/Camaro.html to view picictures of my Camaro!
cigam21 is offline  
post #3 of 4 Old 07-27-2010, 11:53 AM
Veteran Member
 
POWERFREAK's Avatar
 
Join Date: Feb 2008
Location: NY
Posts: 7,873
  
it probably just wasn't fully latched...I can't imagine that happening if anyone was sitting back there.

2010-2SS/RS/LS3/IBM/RP6: ECS-Paxton Supercharger / American Racing Headers & Exhaust / PFADT Suspension / DSS 9" 4.10 Rear / FOR SALE!

Quote:
Originally Posted by Taglane View Post
Powerfreak is the only one who actually understood anything.

Last edited by POWERFREAK; 07-27-2010 at 08:26 PM.
POWERFREAK is offline  
 
post #4 of 4 Old 07-27-2010, 03:33 PM
Supporter of common sense
 
OverAnxious's Avatar
 
Join Date: Mar 2006
Location: Detroit, Michigan
Posts: 9,152
  
Can't see it being an issue. Have a dealer make sure the latches are not faulty if you feel it is a problem

Joe :: Over Anxious 67 Camaro RS/SS L78
5thgenblog.com // Michigan Classics
Chevrolet Camaro in Transformers // My ebaY auctions

Hot Rod Search Google searches for gearheads!
OverAnxious is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome