Power Steering Pump Noise Question - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

 
LinkBack Thread Tools
post #1 of 7 Old 01-01-2011, 10:45 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
 
Power Steering Pump Noise Question

I've had my car stored for the past couple of months due to Winter, but I received some new headers for xmas from the wife and I installed them this weekend. While I was checking for exhaust leaks I noticed a whinning noise coming from what I believe to be the power steering pump. When I turn the wheel slightly in either direction the noise stops. The question i'm hoping someone can help with is: Is this normal?
cwalms is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-02-2011, 11:40 AM
sdk
Veteran Member
 
Join Date: Sep 2009
Location: South Carolina
Posts: 4,974
 
Garage
Checked the fluid?


2017 Camaro SS
South Carolina
sdk is offline  
post #3 of 7 Old 01-02-2011, 05:20 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
 
Quote:
Originally Posted by sdk View Post
Checked the fluid?
yep, it looks good.
cwalms is offline  
 
post #4 of 7 Old 01-02-2011, 05:28 PM
Veteran Member
 
el ess X's Avatar
 
Join Date: May 2007
Location: Aiken, SC
Posts: 3,055
  
Warranty? Then to the dealer it should go. Let them fix it.

FWIW, I had a whiny ps pump on the 06 GMC truck. Not real bad, but I knew it was there and didn't like it. Which GMC/Chevy trucks in that era was known for that issue. Drained out the fluid and replaced it with synthetic fluid and no more noise. Not saying this is what your issue is though...

2010 2SS/RS Auto, Sunroof, Engine Cover. Transformer Edition package.
2013 ZL1 ragtop #5478. 1 of 54 CRT M6 'verts.
el ess X is offline  
post #5 of 7 Old 01-02-2011, 08:04 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
 
Quote:
Originally Posted by el ess X View Post
Warranty? Then to the dealer it should go. Let them fix it.

FWIW, I had a whiny ps pump on the 06 GMC truck. Not real bad, but I knew it was there and didn't like it. Which GMC/Chevy trucks in that era was known for that issue. Drained out the fluid and replaced it with synthetic fluid and no more noise. Not saying this is what your issue is though...
I may try to replace the fluid to see if that works. If not, I'll bring it to the dealer.

thanks for the feed back.
cwalms is offline  
post #6 of 7 Old 01-03-2011, 05:51 AM
Veteran Member
 
el ess X's Avatar
 
Join Date: May 2007
Location: Aiken, SC
Posts: 3,055
  
Be careful doing your own corrective maintenance while the car is under warranty because if it IS a real problem, they could be azz monkeys about it and say since you mucked with it, it's no longer under warranty and you'll eat the costs. Just a thought.

If'n it were me, I'd take it directly to the dealer and let THEM document it, and tell me if it's an issue or not.

2010 2SS/RS Auto, Sunroof, Engine Cover. Transformer Edition package.
2013 ZL1 ragtop #5478. 1 of 54 CRT M6 'verts.
el ess X is offline  
post #7 of 7 Old 01-03-2011, 07:17 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
 
Thanks for the input. I'll probably do just that.
cwalms is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome