check engine light on after oil change - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

Reply
 
LinkBack Thread Tools
post #1 of 15 Old 11-08-2012, 08:21 PM Thread Starter
Member
 
45thAnniversary2SS's Avatar
 
Join Date: Jul 2012
Location: Gastonia, NC
Posts: 134
 
check engine light on after oil change

Just did my first oil change on the SS. 8 qts mobil 1 extended perf 5W30. Reset oil life and put it away. Just cranked it up to go grab some dinner and check engine light was on. Shut her down and taking her in tomorrow morning.

Anyone ever have this issue and might have a suggestion? Maybe disconnect battery for a minute? Manual says 8 qts so not like I overfilled it or anything.

-2012 45th Anniversary 2SS/RS--Pfadt Race Engineering Drop Springs,Razzi Body Kit,Headlight Armor tinted taillights/emblems,Airaid CAI,SW Retro Chambered Catback & SP 1 7/8 Headers with High Flow Cats,JDP Color Changing Halos,P13W Fog Light Upgrade Plasma Bulbs,Fog Light/DRL Harness Kit,Skip Shift Eliminator, Elite Engineering Catch Can
45thAnniversary2SS is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 11-08-2012, 10:42 PM
Junior Member
 
Join Date: Oct 2012
Location: Las Vegas
Posts: 16
 
It could be anything. Just take it to autozone and have them read the code to see what it is first before taking it to the dealership. It could be something as simple as a loose gas cap. Did you put the oil cap back on tight because if not that will trip a CEL also.

Silly Rabbit is offline  
post #3 of 15 Old 11-08-2012, 11:20 PM Thread Starter
Member
 
45thAnniversary2SS's Avatar
 
Join Date: Jul 2012
Location: Gastonia, NC
Posts: 134
 
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?

-2012 45th Anniversary 2SS/RS--Pfadt Race Engineering Drop Springs,Razzi Body Kit,Headlight Armor tinted taillights/emblems,Airaid CAI,SW Retro Chambered Catback & SP 1 7/8 Headers with High Flow Cats,JDP Color Changing Halos,P13W Fog Light Upgrade Plasma Bulbs,Fog Light/DRL Harness Kit,Skip Shift Eliminator, Elite Engineering Catch Can

Last edited by 45thAnniversary2SS; 11-08-2012 at 11:23 PM.
45thAnniversary2SS is offline  
 
post #4 of 15 Old 11-08-2012, 11:40 PM
Junior Member
 
Join Date: Oct 2012
Location: Las Vegas
Posts: 16
 
Quote:
Originally Posted by 45thAnniversary2SS View Post
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?
That's normal for the gauge 2 go up as u accelerate. Cel wouldn't go if it were to high but if it were 2 low it could trip it. Did u double check your oil cap also? If its loose it will let unmetered air in and trip the cel
Silly Rabbit is offline  
post #5 of 15 Old 11-08-2012, 11:43 PM
Bully Proof
 
Envy's Avatar
 
Join Date: Apr 2010
Location: Dallas, TX
Posts: 7,086
  
Garage
Quote:
Originally Posted by 45thAnniversary2SS View Post
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?
That's exactly how my V6's gauges read and is perfectly normal I believe.
Envy is offline  
post #6 of 15 Old 11-09-2012, 07:47 AM
See You On Course
 
CUONCRS's Avatar
 
Join Date: May 2007
Location: Wichita, KS
Posts: 3,867
 
Maybe the low pressure after the oil change caused the initial trip of the CEL, and once it comes up to full pressure, it just needs to be cleared? Just guessing. I changed my own oil, too, but never got the CEL.

2010 Stock IBM 2SS/RS

I found $80 in my jeans pocket. The kid in me said "buy nerf guns and candy!" But then the adult in me said "buy vodka, nerf guns and candy!"

CUONCRS is offline  
post #7 of 15 Old 11-09-2012, 08:13 AM Thread Starter
Member
 
45thAnniversary2SS's Avatar
 
Join Date: Jul 2012
Location: Gastonia, NC
Posts: 134
 
I appreciate everyones response! Just went out and looked over everything and noticed that the CAI had slipped off the throttle body. Pretty sure that was what tripped it. The check engine light is still on, but I'm assuming that will go away after driving for a while. Just ran to McDonalds and back and it's still on..

-2012 45th Anniversary 2SS/RS--Pfadt Race Engineering Drop Springs,Razzi Body Kit,Headlight Armor tinted taillights/emblems,Airaid CAI,SW Retro Chambered Catback & SP 1 7/8 Headers with High Flow Cats,JDP Color Changing Halos,P13W Fog Light Upgrade Plasma Bulbs,Fog Light/DRL Harness Kit,Skip Shift Eliminator, Elite Engineering Catch Can
45thAnniversary2SS is offline  
post #8 of 15 Old 11-09-2012, 08:13 AM
Member
 
Join Date: Nov 2012
Location: Beaufort, NC
Posts: 334
 
Take it and get the code read. Could be anything. Until you do that, there is no point in doing anything else.
coyotekiller is offline  
post #9 of 15 Old 11-09-2012, 09:08 AM
Junior Member
 
Join Date: Oct 2012
Location: Las Vegas
Posts: 16
 
Quote:
Originally Posted by 45thAnniversary2SS View Post
I appreciate everyones response! Just went out and looked over everything and noticed that the CAI had slipped off the throttle body. Pretty sure that was what tripped it. The check engine light is still on, but I'm assuming that will go away after driving for a while. Just ran to McDonalds and back and it's still on..
That will set off your CEL with out a doubt give it about 20 to 50 miles and it will go off
Silly Rabbit is offline  
post #10 of 15 Old 11-09-2012, 09:19 AM Thread Starter
Member
 
45thAnniversary2SS's Avatar
 
Join Date: Jul 2012
Location: Gastonia, NC
Posts: 134
 
Quote:
Originally Posted by Silly Rabbit View Post
That will set off your CEL with out a doubt give it about 20 to 50 miles and it will go off
Thank you sir!

-2012 45th Anniversary 2SS/RS--Pfadt Race Engineering Drop Springs,Razzi Body Kit,Headlight Armor tinted taillights/emblems,Airaid CAI,SW Retro Chambered Catback & SP 1 7/8 Headers with High Flow Cats,JDP Color Changing Halos,P13W Fog Light Upgrade Plasma Bulbs,Fog Light/DRL Harness Kit,Skip Shift Eliminator, Elite Engineering Catch Can
45thAnniversary2SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome