Air filter clips..broken! - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

 
LinkBack Thread Tools
post #1 of 4 Old 04-05-2013, 11:52 AM Thread Starter
Member
 
Turismo's Avatar
 
Join Date: Sep 2009
Posts: 346
 
Air filter clips..broken!

So i like to check my air filter before fireing up my car for the first time after its winter break to make sure no mice have a new home.

I pulled the clips back and both snapped off right at the base! I did not use tools or excessive force in any manor and infact i don't think the clips themselves had even bent far enough to have cleared the top "hood" to have even unclipped before they broke!!

Anyone else experience this? I don't understand how they could have, they even have a little guard to prevent them from bending too far. The plastic looks like a hard, non plyable plastic almost like graphite.

2010 SS/RS

https://www.moderncamaro.com/forum/signaturepics/sigpic6208_1.gif
Turismo is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-06-2013, 05:59 AM
Premium Member
 
patriotpa's Avatar
 
Join Date: Aug 2008
Location: Pennsylvania
Posts: 6,222
  
Garage
Mine have been working just fine since 2009.

James 1:25 Ordered from Faulkner Chevy #NKCF02 1100 5/8/9 2000, 3300 7/16/9 TPW 7/20,GOT MY (low) VIN! 4000 7/24/9 ,Picked up 8/7/9!!! Signed Litho #45. Car signed by FBodfather 2011. Service: Jennings Chevy in PA. We don't "drift", kiddies... we POWER SLIDE! MOTM/COTM Sept 2012 Pro Patria Vigilans.
Click the pic.. I don't tolerate fools.
patriotpa is offline  
post #3 of 4 Old 04-06-2013, 06:45 AM
Senior Member
 
skuttduck's Avatar
 
Join Date: Aug 2010
Location: East Lansing, MI
Posts: 588
 
Same here. I had a problem when I installed my K&N filter that I had to wedge something in there to close the last clip, but they have never broken.
skuttduck is offline  
 
post #4 of 4 Old 04-09-2013, 06:42 AM
Member
 
Poohdogger's Avatar
 
Join Date: Dec 2011
Posts: 158
 
Time for a cai.....

Custom installer 25 years in the game............ owner of Voo Doo Customs
Poohdogger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome