Anti-freeze smell... - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

 
LinkBack Thread Tools
post #1 of 8 Old 09-30-2013, 09:11 AM Thread Starter
Member
 
Turismo's Avatar
 
Join Date: Sep 2009
Posts: 346
 
Anti-freeze smell...

Ahh the good ol' smell of maple syrup in the morning...wait what?!?


So i've got not leaks that are making it to the ground, and nothing visible under the hood, nor does it smell at all.

In the cabin however, i get a good strong smell which usually dissipates shortly after start up. My temp is fine, heater works, and the smell doesn't get worse when its turned up (hot or cold) and actually smells less when its blowing on high.

Heater core f*cked?

I sure hope not, if a car with just over 20k miles that is parked every winter in a garage has heater core issues already my warm fuzzy American made gusto is gonzo.

https://www.moderncamaro.com/forum/signaturepics/sigpic6208_1.gif
Turismo is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-30-2013, 09:50 AM
Veteran Member
 
kc0cmj's Avatar
 
Join Date: Aug 2010
Location: Springfield, Mo
Posts: 1,534
 
Garage
I would say heater core. I have done about 4 of them in my shop last year. Don't be suprised when they tell you they have to pull the windshield out. A few of the bolts are not accessible without pulling the windshield out to get to them. And yes, the entire dash comes out as well.

2010 Camaro 2SS/RS 6spd 426hp
December 2013 Member of the Month
kc0cmj is offline  
post #3 of 8 Old 09-30-2013, 05:25 PM
Member
 
Chevy Customer Service's Avatar
 
Join Date: Oct 2012
Location: Michigan
Posts: 383
        
Quote:
Originally Posted by Turismo View Post
Ahh the good ol' smell of maple syrup in the morning...wait what?!?


So i've got not leaks that are making it to the ground, and nothing visible under the hood, nor does it smell at all.

In the cabin however, i get a good strong smell which usually dissipates shortly after start up. My temp is fine, heater works, and the smell doesn't get worse when its turned up (hot or cold) and actually smells less when its blowing on high.

Heater core f*cked?

I sure hope not, if a car with just over 20k miles that is parked every winter in a garage has heater core issues already my warm fuzzy American made gusto is gonzo.
Turismo,

I do apologize for reading about your vehicle concerns. I understand that you're seeking opinions of this matter, and wanted you to know that we're also here if you need additional assistance. Feel free to send me a message if needed.

William R.
Chevrolet Customer Care



Available 8:00 AM - 12:00 AM EST
Chevy Customer Service is offline  
 
post #4 of 8 Old 09-30-2013, 06:16 PM
Member
 
Pumpkin's Avatar
 
Join Date: Aug 2013
Location: Sullivan, ohio
Posts: 135
 
Wow the windshield has to come out!!! Eeeewh. I just replaced the heater core in my Colorado, and it was a hard 5 hours laying upside down lol!!

NEOCC Member since 2013
Pumpkin is offline  
post #5 of 8 Old 10-10-2013, 10:04 PM Thread Starter
Member
 
Turismo's Avatar
 
Join Date: Sep 2009
Posts: 346
 
Meh, i'll check it out at some other time, as i said i park it for the winter so i don't use the heater much anyways.

Thanks Chevy Customer Service, the irony had to be when i checked my warranty and it had expired the month before. Guessing i should fear my final payment as well?

I hate to beat a dead horse cause i've probably said this before but its sad that i've had a subaru wrx for 12 years and the only things i've replaced are the brakes and O2 sensors.

https://www.moderncamaro.com/forum/signaturepics/sigpic6208_1.gif
Turismo is offline  
post #6 of 8 Old 10-11-2013, 03:59 PM
Member
 
Chevy Customer Service's Avatar
 
Join Date: Oct 2012
Location: Michigan
Posts: 383
        
Quote:
Originally Posted by Turismo View Post
Meh, i'll check it out at some other time, as i said i park it for the winter so i don't use the heater much anyways.

Thanks Chevy Customer Service, the irony had to be when i checked my warranty and it had expired the month before. Guessing i should fear my final payment as well?

I hate to beat a dead horse cause i've probably said this before but its sad that i've had a subaru wrx for 12 years and the only things i've replaced are the brakes and O2 sensors.
You're welcome,

I definitely realize the displeasure those types of circumstances can create for you. If you feel action needs to be taken, we're available via PMs for further assistance.

William R.
Chevrolet Customer Care



Available 8:00 AM - 12:00 AM EST
Chevy Customer Service is offline  
post #7 of 8 Old 10-12-2013, 01:13 PM
ユキヒョウ
 
Nancygrl's Avatar
 
Join Date: Jul 2011
Posts: 1,439
 
When I had my 2010 LS3, I had the same thing. It wasn't the heater core. Turned out to be a coolant fitting. There is a real big coolant fitting driver's side of the block that was ever so slightly loose. The coolant wasn't making it to the ground because it is right over part of the front cradle. Was real hard to spot. Hope it helps.

2019 1SS/1LE
Nancygrl is offline  
post #8 of 8 Old 10-15-2013, 08:41 AM Thread Starter
Member
 
Turismo's Avatar
 
Join Date: Sep 2009
Posts: 346
 
Thanks Nancygrl, i'll look into that for sure, only thing that tells me its not that is i can't smell "the smell" anywhere but the cabin, when i pop the hood i can sniff everywhere and not a whiff =/

But its worth a check! *crosses fingers*

https://www.moderncamaro.com/forum/signaturepics/sigpic6208_1.gif
Turismo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome