2010 camaro wont start - ModernCamaro.com - 5th Generation Camaro Enthusiasts
General Technical Discussion General 5th Gen Tech
Anything that doesn't fit in one of the above categories goes here.

 
LinkBack Thread Tools
post #1 of 2 Old 01-07-2018, 06:04 PM Thread Starter
Newbie
 
Join Date: Jan 2018
Posts: 1
 
2010 camaro wont start

hi, new to this forum, and searched to see if anyone else has had this issue and didnt see anything that looked along these lines. first of all i have a 2010 camaro ls v6 automatic. so here is whats going on. i got in my car put the key in turned the switch everything came on (air, instrument panel, radio etc, even windows worked) but when i turned the key to crank the car....nothing...no clicking, no nothing. got to googling and couldnt find anything, started lookin under the hood found a blown fuse, replaced it, and it blew again as soon as i turned the switch. searched the wires the best i could to see if there was a bare spot and couldint find one, swapped relays, and replaced the starter yesterday night, got in turned the switch on and it still didnt crank, still didnt make any sounds either. and its still blowing fuses. any help would be appreciated. thanks in advance.
Acrophobic10 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 01-08-2018, 12:16 PM
Premium Member
 
patriotpa's Avatar
 
Join Date: Aug 2008
Location: Pennsylvania
Posts: 6,222
  
Garage
What's the label on the fuse that's blowing? SOMETHING is drawing too much current. Once we know which fuse it is, then we can start trying to help.

Also, has the car had any wiring added or changed? Has the stereo been changed? Lights added? More info is better.

James 1:25 Ordered from Faulkner Chevy #NKCF02 1100 5/8/9 2000, 3300 7/16/9 TPW 7/20,GOT MY (low) VIN! 4000 7/24/9 ,Picked up 8/7/9!!! Signed Litho #45. Car signed by FBodfather 2011. Service: Jennings Chevy in PA. We don't "drift", kiddies... we POWER SLIDE! MOTM/COTM Sept 2012 Pro Patria Vigilans.
Click the pic.. I don't tolerate fools.
patriotpa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome