Canon digital Rebel XTI giving me trouble - ModernCamaro.com - 5th Generation Camaro Enthusiasts
The MC Lounge General Discussions. Disrespectful behavior will not be tolerated.
POLITICAL AND/OR RELIGIOUS CONTENT IS PROHIBITED

Reply
 
LinkBack Thread Tools
post #1 of 12 Old 08-14-2011, 01:41 PM Thread Starter
Supporting Super Moderator
 
brandonppr's Avatar
 
Join Date: Jul 2006
Location: Middle TN
Posts: 5,668
 
Canon digital Rebel XTI giving me trouble

My XTI camera has been getting really slow at taking pics lately. Sometimes it won't even take in regular mode at all. Sometimes I have trouble getting it to take in any mode.

Any idea what could be slowing it down?

It has a 8 gig CF card that is almost full, would a full card slow it down? any other ideas?

1998 Camaro A4 7.06 @ 96.5 MPH NA 1.47 best 60ft
2010 Camaro Tube Chassis work in progress
brandonppr is offline  
post #2 of 12 Old 08-14-2011, 04:29 PM
Veteran Member
 
Buzz's Avatar
 
Join Date: Feb 2011
Location: Holly Springs, Georgia
Posts: 1,260
 
Garage
I have a Canon T1i model myself. Check the SDHC memory card type you are using. I use SanDisk Extreme with 30MB/s rate. Anytime when I use generic SDHC card, mine just flips out. Hopefully this helps.


Buzz
2010 Synergy Green 1LT

Buzz is offline  
post #3 of 12 Old 08-14-2011, 04:31 PM
Veteran Member
 
Buzz's Avatar
 
Join Date: Feb 2011
Location: Holly Springs, Georgia
Posts: 1,260
 
Garage
Also my father did confirm that digital SLR cameras need the higher speed cards.

Buzz
2010 Synergy Green 1LT

Buzz is offline  
post #4 of 12 Old 08-14-2011, 05:26 PM
Bully Proof
 
Envy's Avatar
 
Join Date: Apr 2010
Location: Dallas, TX
Posts: 7,086
  
Garage
How old is the battery? If it's at the end of it's life...and not charging fully...it can definitely cause slow/no response.
Envy is offline  
post #5 of 12 Old 08-14-2011, 05:56 PM Thread Starter
Supporting Super Moderator
 
brandonppr's Avatar
 
Join Date: Jul 2006
Location: Middle TN
Posts: 5,668
 
I'm going to empty the card first.

If that don't help maybe I will try getting a new memory card. I hate CF cards. The next year after I got mine they switched to SD. Do you think a CF SD adapter will cause any trouble?


Quote:
Originally Posted by Envy View Post
How old is the battery? If it's at the end of it's life...and not charging fully...it can definitely cause slow/no response.
The battery seems to be fine and it holds a charge for a long time.

1998 Camaro A4 7.06 @ 96.5 MPH NA 1.47 best 60ft
2010 Camaro Tube Chassis work in progress
brandonppr is offline  
post #6 of 12 Old 08-14-2011, 06:06 PM
Veteran Member
 
Buzz's Avatar
 
Join Date: Feb 2011
Location: Holly Springs, Georgia
Posts: 1,260
 
Garage
Not sure on the CF SD adapter. Another though to see if there is code update from Canon on that model.

Buzz
2010 Synergy Green 1LT

Buzz is offline  
post #7 of 12 Old 08-14-2011, 06:13 PM Thread Starter
Supporting Super Moderator
 
brandonppr's Avatar
 
Join Date: Jul 2006
Location: Middle TN
Posts: 5,668
 
Quote:
Originally Posted by Buzz View Post
Not sure on the CF SD adapter. Another though to see if there is code update from Canon on that model.
I didn't even know it could be updated.

1998 Camaro A4 7.06 @ 96.5 MPH NA 1.47 best 60ft
2010 Camaro Tube Chassis work in progress
brandonppr is offline  
post #8 of 12 Old 08-14-2011, 06:29 PM
Veteran Member
 
Buzz's Avatar
 
Join Date: Feb 2011
Location: Holly Springs, Georgia
Posts: 1,260
 
Garage
Now I basing that the T1i model. Not sure how far apart we are in generations in SLR's. I would check the Canon web site for any information. Let me know what you find. Good luck.

Buzz
2010 Synergy Green 1LT

Buzz is offline  
post #9 of 12 Old 08-14-2011, 07:17 PM Thread Starter
Supporting Super Moderator
 
brandonppr's Avatar
 
Join Date: Jul 2006
Location: Middle TN
Posts: 5,668
 
Tried emptiing the memory card and that didn't work Guess I will try getting another card.

1998 Camaro A4 7.06 @ 96.5 MPH NA 1.47 best 60ft
2010 Camaro Tube Chassis work in progress
brandonppr is offline  
post #10 of 12 Old 08-16-2011, 09:34 AM
Veteran Member
 
POWERFREAK's Avatar
 
Join Date: Feb 2008
Location: NY
Posts: 7,873
  
Did you try reformatting the card?

A card adapter will slow things down even more (plus CF cards are typically faster then SD cards anyway). A faster card should help, as buzz said, the sandisk extreme cards are one of the fastest around. Newegg.com has some good prices on them (link below). A faster card will also speed up transfer times (to your computer).

The canon website will most likely have a list of recommend cards that are known to work well for your camera, maybe the camera has issues with your particular card.

Also you can check the canon website for firmware updates for the camera, might help.


http://www.newegg.com/Product/Product.aspx?Item=N82E16820171355

2010-2SS/RS/LS3/IBM/RP6: ECS-Paxton Supercharger / American Racing Headers & Exhaust / PFADT Suspension / DSS 9" 4.10 Rear / FOR SALE!

Quote:
Originally Posted by Taglane View Post
Powerfreak is the only one who actually understood anything.

Last edited by POWERFREAK; 08-16-2011 at 09:38 AM.
POWERFREAK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome