BURNING SMELL - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

 
LinkBack Thread Tools
post #1 of 5 Old 01-08-2012, 07:01 PM Thread Starter
Junior Member
 
Aktos's Avatar
 
Join Date: Dec 2011
Location: Frisco, Tx
Posts: 28
 
Garage
BURNING SMELL

I have a 2SS automatic with a burnt Oil/plastic smell and I am at 1265 miles. I just got it home and do not smell it now. Found no oil leaks or anything, the engine compartment just smells like hot engine. I could smell it when car was running especially when coming to a stop at a light. It has always had kind of a burn oil type smell in garage since I bought it just figured it was new parts heating up oil coating but at this many miles I am begining to wonder. Anyone else notice this?
Aktos is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 01-08-2012, 07:22 PM
sdk
Veteran Member
 
Join Date: Sep 2009
Location: South Carolina
Posts: 4,977
 
Garage
Mine smelled for about 2-3 weeks. My dealer said it was normal and to expect it.


2017 Camaro SS
South Carolina
sdk is offline  
post #3 of 5 Old 01-09-2012, 03:48 AM
MODERATOR
 
Camaro Freak's Avatar
 
Join Date: Nov 2010
Location: NC
Posts: 3,081
 
Mine did to. It will go away soon. Just the new burning off.


JANUARY 2012 MODERN CAMARO MEMBER OF THE MONTH
JUNE 2012 CAMARONEWS.COM CAR OF THE MONTH
http://5thgencarolinacamaros.webs.com/
Camaro Freak is offline  
 
post #4 of 5 Old 01-09-2012, 07:38 PM
ユキヒョウ
 
Nancygrl's Avatar
 
Join Date: Jul 2011
Posts: 1,439
 
1265 miles isn't a whole lot. Took 2-3 weeks of daily driving before the smells went away.

2019 1SS/1LE
Nancygrl is offline  
post #5 of 5 Old 01-09-2012, 08:11 PM Thread Starter
Junior Member
 
Aktos's Avatar
 
Join Date: Dec 2011
Location: Frisco, Tx
Posts: 28
 
Garage
Ok thanks will give it some more time. Just curious if anybody else had same problem
Aktos is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome