Water pump leaking - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

Reply
 
LinkBack Thread Tools
post #1 of 14 Old 04-07-2014, 08:53 AM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Water pump leaking

I was working on my car yesterday changing the oil.Noticed a small spot of antifreeze on the floor ,checked the hoses no leaks.Started the car and noticed little beeds of fluid landing on my fender and hood.Shut the car off and it was dripping down from behind the pump and the floor had about a 1/2 a cup of antifreeze on the ground.After searching I found it was coming from the back of the water pump some where in the middle.Does anyone know if there is a seep hole in the back of the pump.I know older cars do and if they are leaking the seal is bad.It only does it when it is running.Any help would be appreciated.Going to pull it tonight and take a better look.Its a 2010 2 ss/rs a6
22,000 on it.


May 2014 MC Member of the Month!
MidlifeSS is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 04-07-2014, 09:09 AM
Veteran Member
 
kc0cmj's Avatar
 
Join Date: Aug 2010
Location: Springfield, Mo
Posts: 1,534
 
Garage
Water pumps are part of the powertrain warranty 5 year or 100,000 miles.. should be free at your local Chevy Dealer.

2010 Camaro 2SS/RS 6spd 426hp
December 2013 Member of the Month
kc0cmj is offline  
post #3 of 14 Old 04-07-2014, 01:10 PM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Probably not with my mods ,tune and all the other stuff.Also rather not have them scratch up my car or cause any others damage.haven't had to good of luck with dealers here.


May 2014 MC Member of the Month!
MidlifeSS is offline  
 
post #4 of 14 Old 04-07-2014, 06:07 PM
Veteran Member
 
Chapel's Avatar
 
Join Date: May 2012
Posts: 1,690
 
Quote:
Originally Posted by MidlifeSS View Post
Probably not with my mods ,tune and all the other stuff.Also rather not have them scratch up my car or cause any others damage.haven't had to good of luck with dealers here.
You don't have any mods that will cause a water pump to go bad. So technically they CAN replace it. However, if your contract states that any mods will void your warranty, then they can void it. Just so you know tho, I looked at my carfax report on my car and I saw that somewhere below 5,000 miles my water pump was replaced. So maybe this is a common problem. Either way a water pump is not really a major repair. But you should at least bring it to them because maybe they will fix it.

2017 Camaro ZL-1 A10

2013 Jeep Grand Cherokee Hemi 5.7 - Tuned!!

Proud to be the March 2013 Member Of The Month!
Chapel is offline  
post #5 of 14 Old 04-08-2014, 07:09 AM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Thanks for the advice guys.I ended up pulling it last night(only took 30 minutes) found the leak.There is a pressed in shallow cup around 4 inches in diameter on the back side of the pump it was leaking at the bottom of it.Ordered one off Amazon for $127.00 shipped ac delco oem part,everywhere else wanted 170.00 to 450.Checked some of the parts stores in my area and no one even showed one.I will post a pic of the leak this afternoon.


May 2014 MC Member of the Month!

Last edited by MidlifeSS; 04-09-2014 at 09:20 PM.
MidlifeSS is offline  
post #6 of 14 Old 04-08-2014, 04:45 PM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Here's where it was leaking ,see pic bellow.So if you start getting a belt chip/noise and you change your belts and it still does the chip/noise.You may want to check for a leak on the back side of the pump.It drips down on to the crank and flings it onto the belts and everything else when you first start it.Then when it starts to warms up it stops leaking and the belt noise goes away,because the metal expands.In the beginning I thought it was the billet tensioner and billet idler pulleys and the race belts making the noise.
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	201
Size:	100.1 KB
ID:	35225  


May 2014 MC Member of the Month!
MidlifeSS is offline  
post #7 of 14 Old 04-09-2014, 06:39 PM
Member
 
S.Bretz's Avatar
 
Join Date: Jan 2013
Location: Lutz, FL
Posts: 384
 
If they where dicks and scanned the ECM calibration, they could possibly voided the warranty. But they would still have to sent the calibration values off to GM for validation before the warranty was void.

I had to send off calibrations for GM because we had a customer bragging to the tech about the mods he had and that he had to get the ECM "tuned." I took the pictures of the calibration and sent them off..... GM got back and said "He just had the tire size changes, go ahead with the repairs." The guy had different size wheels on it but also had ported heads, a smaller pulley, aftermarket header and exhaust, and an intake and it we still fixed the coolant leak (on the back of the engine) under warranty.

Your dealer has to prove that the mods caused direct failure of the parts. If they say no...Call Chevy customer service and CAC case started (Customer assistance center) ...that will get a fire under the manager's feet. It probably a common failure too...so then they cannot dispute your mods had anything to do with it.
S.Bretz is offline  
post #8 of 14 Old 04-10-2014, 07:10 AM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Quote:
Originally Posted by S.Bretz View Post
If they where dicks and scanned the ECM calibration, they could possibly voided the warranty. But they would still have to sent the calibration values off to GM for validation before the warranty was void.

I had to send off calibrations for GM because we had a customer bragging to the tech about the mods he had and that he had to get the ECM "tuned." I took the pictures of the calibration and sent them off..... GM got back and said "He just had the tire size changes, go ahead with the repairs." The guy had different size wheels on it but also had ported heads, a smaller pulley, aftermarket header and exhaust, and an intake and it we still fixed the coolant leak (on the back of the engine) under warranty.

Your dealer has to prove that the mods caused direct failure of the parts. If they say no...Call Chevy customer service and CAC case started (Customer assistance center) ...that will get a fire under the manager's feet. It probably a common failure too...so then they cannot dispute your mods had anything to do with it.
Thanks for info,but it's not worth the head ache to me.Mine has more than just the tire size adjusted.Fans adjusted to come on sooner,adjusted for 3.91 gears in a auto,fuel adjusted,trans adjusted,torque management adjusted and so on.Also have a lot of custom painted parts under the hood I don't want tore up by a mechanic who does not give two sh!/$ about my car.I have already dealt with this in the past and they deny doing any damage.I have worked on cars for 35 years so fixing them is no problem for me.New part will be here tomorrow and will be back together tomorrow.


May 2014 MC Member of the Month!
MidlifeSS is offline  
post #9 of 14 Old 04-13-2014, 07:41 AM Thread Starter
Senior Member
 
MidlifeSS's Avatar
 
Join Date: Apr 2012
Location: Northern Vermont
Posts: 533
 
Garage
Got my new pump in no more leaks.FYI if you get a ac delco water pump,it comes with a new thermostat and goose neck assembled,also new gaskets.


May 2014 MC Member of the Month!
MidlifeSS is offline  
post #10 of 14 Old 04-13-2014, 09:28 AM
Support MC & Troops
 
hotrodhoodrat's Avatar
 
Join Date: Oct 2010
Location: Idaho
Posts: 11,784
 
Sweet, thats great news..



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

Getting way pumped up ..LOL(Never giving up !)

The all new Convertible (Born 1/11/11) !, Welcome to the Fleet !
SHADOW 2013 GBA 2SS/RS A6 Vert (2/13/14)
"FROST 2011 SIM LT1 A6 " FIRST VERT MOTM AUGUST 2013
*PROTESTING GM*
"GIVE ME MY13'IBM ZL1 vert GM!"
hotrodhoodrat is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome