Reduced Engine Power - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

Reply
 
LinkBack Thread Tools
post #1 of 14 Old 05-04-2015, 08:33 AM Thread Starter
Premium Member
 
Join Date: Jul 2013
Location: Oklahoma
Posts: 90
 
Reduced Engine Power

Hey Folks,

I haven't been on in a while. Not sure I'll even have my Camaro much longer. A few months ago I was driving and got a message (reduced engine power) Every light you can imagine lit up and it had about half power at the most. I made it to my destination, shut it off and it started back up but still with no power and all the lights. I shut it off, went in and bowled and came back out 3.5 hours later and it started up with full power. The only light on was the engine light. So I made it home just fine. The next day the engine light was gone so I ignored it and all went well for a month or so. Then it happened again. This time it wouldn't start back up so I had it towed. They kept it for a week and a half and put regular unleaded in it. I can't prove this but know when I got it back it wasn't acting right. Ok, so.. It lasted this time maybe 2 months and it happened again at a drive thru window. I had to have someone help me push it. So now, I waited several hours and it started. I drove it to the dealer which luckily is close. They looked at it again for 1 day. Replaced the ECM. This solved the issue with reduced power from having regular unleaded gas. But I picked up my car at 4pm and by 6pm I was stranded again only this time, right on top of railroad tracks. I couldn't push the car off but luckily a train wasn't near and then a woman and 3 guys helped me push it off. Now, I have researched this issue and told them from day one that it sounds like an issue with a sensor on the throttle body but they will not replace it? So now I have to go on a weekend trip that's really important on the 9th and 10th and I literally don't trust the car anymore. I don't know that I'll get it back by then anyway. I'm driving a loaner. This is actually the 4th time It's happened now and 3rd time I've been completely stranded. It's fairly dangerous losing power. And getting stuck on train tracks? They didn't even act like it was a big deal. It's pretty sad when you love a car but don't even want it back because you're worried you'll be stranded or worse. I'm trying to be nice with them but it's getting past that point. I'm thinking about contacting GM. The car is a '13 and I don't think I should have to worry about such things. What would you all do? I almost wish they'd just take that thing back and give me a new one after all this. At least I told my kids if something happens to me because of this issue they'll be rich. lol Anyone have any issues like this?
Storm T is offline  
Sponsored Links
Advertisement
 
post #2 of 14 Old 05-04-2015, 11:05 AM
Veteran Member
 
kc0cmj's Avatar
 
Join Date: Aug 2010
Location: Springfield, Mo
Posts: 1,534
 
Garage
I would go to another dealer, if you haven't already talked to the service manager at the one you are at. Putting unleaded in it has nothing to do with this problem.

Sounds like either a throttle position sensor or accelerator position sensor.

2010 Camaro 2SS/RS 6spd 426hp
December 2013 Member of the Month
kc0cmj is offline  
post #3 of 14 Old 05-04-2015, 11:47 AM Thread Starter
Premium Member
 
Join Date: Jul 2013
Location: Oklahoma
Posts: 90
 
Yeah, I know it's 2 different issues. I was just saying. I did speak with the service mgr. and he displayed an attitude of not caring much. I have even told them from day one after researching it that it's the throttle body. I dunno. They've had it since Thursday this time.
Storm T is offline  
 
post #4 of 14 Old 05-07-2015, 09:33 AM
Junior Member
 
Join Date: Mar 2014
Location: Austin, TX
Posts: 53
 
If they have been displaying an attitude of indifference, and the car has been leaving you in precarious situations, I would definitely call GM and raise the issue up with them.
sebian is offline  
post #5 of 14 Old 05-13-2015, 06:28 PM Thread Starter
Premium Member
 
Join Date: Jul 2013
Location: Oklahoma
Posts: 90
 
Let's hope this last round got it fixed. I wouldn't even drive it for my weekend trip this past weekend. I didn't trust it so I took an office vehicle. Pretty sad. So far it's been fine for a few days. We'll see.
Storm T is offline  
post #6 of 14 Old 05-26-2015, 06:49 AM
Member
 
Join Date: Jul 2013
Location: Chicagoland
Posts: 127
 
Tell us again why you stopped on railroad tracks?
Comrando is offline  
post #7 of 14 Old 06-04-2015, 11:00 AM
Veteran Member
 
Chapel's Avatar
 
Join Date: May 2012
Posts: 1,690
 
Quote:
Originally Posted by Comrando View Post
Tell us again why you stopped on railroad tracks?
When the car goes into "Reduced Power Mode". the power from the engine is cut, sometimes severely. The engine might not even have enough power to move the car. He didn't "stop" on the tracks. The car lost power and he got stuck there.


Quote:
Originally Posted by Storm T View Post
Hey Folks,

I haven't been on in a while. Not sure I'll even have my Camaro much longer. A few months ago I was driving and got a message (reduced engine power) Every light you can imagine lit up and it had about half power at the most. I made it to my destination, shut it off and it started back up but still with no power and all the lights. I shut it off, went in and bowled and came back out 3.5 hours later and it started up with full power. The only light on was the engine light. So I made it home just fine. The next day the engine light was gone so I ignored it and all went well for a month or so. Then it happened again. This time it wouldn't start back up so I had it towed. They kept it for a week and a half and put regular unleaded in it. I can't prove this but know when I got it back it wasn't acting right. Ok, so.. It lasted this time maybe 2 months and it happened again at a drive thru window. I had to have someone help me push it. So now, I waited several hours and it started. I drove it to the dealer which luckily is close. They looked at it again for 1 day. Replaced the ECM. This solved the issue with reduced power from having regular unleaded gas. But I picked up my car at 4pm and by 6pm I was stranded again only this time, right on top of railroad tracks. I couldn't push the car off but luckily a train wasn't near and then a woman and 3 guys helped me push it off. Now, I have researched this issue and told them from day one that it sounds like an issue with a sensor on the throttle body but they will not replace it? So now I have to go on a weekend trip that's really important on the 9th and 10th and I literally don't trust the car anymore. I don't know that I'll get it back by then anyway. I'm driving a loaner. This is actually the 4th time It's happened now and 3rd time I've been completely stranded. It's fairly dangerous losing power. And getting stuck on train tracks? They didn't even act like it was a big deal. It's pretty sad when you love a car but don't even want it back because you're worried you'll be stranded or worse. I'm trying to be nice with them but it's getting past that point. I'm thinking about contacting GM. The car is a '13 and I don't think I should have to worry about such things. What would you all do? I almost wish they'd just take that thing back and give me a new one after all this. At least I told my kids if something happens to me because of this issue they'll be rich. lol Anyone have any issues like this?
Sorry that you're having this issue and hopefully it has been resolved by now. These are the reasons I choose to do my own work including diagnosing my own problems. I always recommend for everyone to go get themselves a DTC reader/eraser. That way, when stuff happens, you can know exactly what the problem is and fix it yourself if it is a fix you feel comfortable doing. I had a "Reduced Power" warning recently. It was related to the throttle positioning. I resolved it myself. I would say that if the dealership is not gonna help you, then go on Ebay or Craigslist or a forum classified section and buy a used throttle body that still has it's own electronics in it. Then install it yourself and see if that fixes it. A TB install is literally a 15 min job. If that solves your problem then take the faulty one to Chevy and give them hell.

2017 Camaro ZL-1 A10

2013 Jeep Grand Cherokee Hemi 5.7 - Tuned!!

Proud to be the March 2013 Member Of The Month!
Chapel is offline  
post #8 of 14 Old 06-04-2015, 01:38 PM
Veteran Member
 
kc0cmj's Avatar
 
Join Date: Aug 2010
Location: Springfield, Mo
Posts: 1,534
 
Garage
^^ Coming from a GM standpoint.. You won't get your money back, especially using a used part. Find another dealer and be nice and don't be a know it all.. Squeaky wheel does not do as much as the extremely nice person that wants some help. That has always been my aspect being the Service Manager.. Loud know it alls are horrible to deal with and it makes me not want to help them.. Nice people who ask will get my attention... Just my .02

2010 Camaro 2SS/RS 6spd 426hp
December 2013 Member of the Month
kc0cmj is offline  
post #9 of 14 Old 06-04-2015, 02:26 PM
Veteran Member
 
Chapel's Avatar
 
Join Date: May 2012
Posts: 1,690
 
Quote:
Originally Posted by kc0cmj View Post
^^ Coming from a GM standpoint.. You won't get your money back, especially using a used part. Find another dealer and be nice and don't be a know it all.. Squeaky wheel does not do as much as the extremely nice person that wants some help. That has always been my aspect being the Service Manager.. Loud know it alls are horrible to deal with and it makes me not want to help them.. Nice people who ask will get my attention... Just my .02
That is because you are polite and a nice person. But my experiences with shops and dealers have been the opposite. I wish more were like yourself. I've found in my dealings that every time I've tried to be nice or be patient, I was taken advantage of. I'd go into a shop and leave my car. A week later I'd find my car was still in the same spot I left it in and wasn't even looked at. So I'd be nice and polite and ask about it and I'd get the run around. But then I'd see someone else come in and they'd be in and out in a couple days...and my car would still be just sitting there. And all the loud mouths and guys who came in like jerks would get the best service on the planet. That is until the day I went to the shop, walked in, asked for my keys, and when they asked me why, I raised hell. After that I learned not to be a push over with dealers or shops. OP here is getting the run around. They are clearly expressing a lack of concern for his predicament and even for his general safety. At this point, I'd walk in there with guns blazing.

2017 Camaro ZL-1 A10

2013 Jeep Grand Cherokee Hemi 5.7 - Tuned!!

Proud to be the March 2013 Member Of The Month!
Chapel is offline  
post #10 of 14 Old 06-04-2015, 05:04 PM
Member
 
S.Bretz's Avatar
 
Join Date: Jan 2013
Location: Lutz, FL
Posts: 384
 
How do you know its a throttle body issue?
Reduce power mode can come form many different problems from loss of communication on a data network between modules or a faulty sensor (pick one).
S.Bretz is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome