An in-depth look at Camaro's LS3 - Page 3 - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

Reply
 
LinkBack Thread Tools
post #21 of 32 Old 05-24-2009, 11:50 AM
MODERATOR
 
54inches's Avatar
 
Join Date: Dec 2006
Location: Dirty Bay, Texas
Posts: 8,984
  
TTT for the new girls.

2005 CTSV BLACK LS7 Clutch/Flywheel/Slave, Tick Speed Bleeder, Tilton Clutch MC, RevShift Bushings, Domestic V8 Solutions (shifter, 8.8 Diff conversion, srut tower braces, sub-frame connectors), SLP cats, no cags, xpipe, bullet mufflers, Volante, iPod dock, G-force tune; 379hp 381tq.

Killing 5th gens like it is my job.
54inches is offline  
Sponsored Links
Advertisement
 
post #22 of 32 Old 02-24-2010, 05:23 PM
Junior Member
 
MC3Designs's Avatar
 
Join Date: Feb 2010
Location: Dallas, Texas
Posts: 51
 
does anyone have an indepth analysis on the L99?....some say its the same engine....what changes did they make to it if any? wasnt the L99 in the old cop cars?... having a corvette engine sounds so much better.. im still torn between manual vs Auto...
MC3Designs is offline  
post #23 of 32 Old 02-24-2010, 05:29 PM
Veteran Member
 
Luwinkle's Avatar
 
Join Date: Jul 2007
Location: Louisville, KY
Posts: 10,420
 


L99 has a few different things (cams, etc) for AFM/DOD to work.
Other than that..it's the same engine. Except for having 30 less HP.

Go manual.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Quote:
Originally Posted by Jeremy Clarkson
A turbo, exhaust gasses go into the turbocharger and spin it, with a supercharger, air goes in, witchcraft happens and you go faster.
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
Luwinkle is offline  
 
post #24 of 32 Old 02-24-2010, 05:54 PM
Junior Member
 
MC3Designs's Avatar
 
Join Date: Feb 2010
Location: Dallas, Texas
Posts: 51
 
Quote:
Originally Posted by Luwinkle View Post


L99 has a few different things (cams, etc) for AFM/DOD to work.
Other than that..it's the same engine. Except for having 30 less HP.

Go manual.
isnt the L99 built to get off the line quicker? and mods are easier done with auto?
MC3Designs is offline  
post #25 of 32 Old 02-24-2010, 06:03 PM
MODERATOR
 
54inches's Avatar
 
Join Date: Dec 2006
Location: Dirty Bay, Texas
Posts: 8,984
  
Quote:
Originally Posted by MC3Designs View Post
isnt the L99 built to get off the line quicker? and mods are easier done with auto?
google.com

2005 CTSV BLACK LS7 Clutch/Flywheel/Slave, Tick Speed Bleeder, Tilton Clutch MC, RevShift Bushings, Domestic V8 Solutions (shifter, 8.8 Diff conversion, srut tower braces, sub-frame connectors), SLP cats, no cags, xpipe, bullet mufflers, Volante, iPod dock, G-force tune; 379hp 381tq.

Killing 5th gens like it is my job.
54inches is offline  
post #26 of 32 Old 02-24-2010, 06:12 PM
Veteran Member
 
Luwinkle's Avatar
 
Join Date: Jul 2007
Location: Louisville, KY
Posts: 10,420
 
If it gets off the line quicker it's because of the auto transmission, not the engine.
Mods are pretty much the same from what I understand. Except you'd need a different exhaust because of the whole resonator thing.



Never pay again for live sex! | Hot girls doing naughty stuff for free! | Chat for free!

Quote:
Originally Posted by Jeremy Clarkson
A turbo, exhaust gasses go into the turbocharger and spin it, with a supercharger, air goes in, witchcraft happens and you go faster.
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
Luwinkle is offline  
post #27 of 32 Old 02-24-2010, 10:15 PM
Veteran Member
 
mucker15's Avatar
 
Join Date: Jan 2009
Location: Levittown LI
Posts: 1,782
 
Its the tranny i dusted my buddy off the line, the new autos are sick, getting it tuned soon so it will shift even better

mucker15 is offline  
post #28 of 32 Old 07-05-2010, 12:41 PM
Newbie
 
Join Date: Dec 2009
Location: Annandale, NJ
Posts: 4
 
High oil temp?

Last week I was at VIR for two days the air temp was 95 plus. My oil temp after a run was 275 is that too high? Should I have used 15/50 oil instead of 5/30. My water temp was about 195.
Bernie Hover is offline  
post #29 of 32 Old 07-05-2010, 12:58 PM
Veteran Member
 
POWERFREAK's Avatar
 
Join Date: Feb 2008
Location: NY
Posts: 7,873
  
Quote:
Originally Posted by Bernie Hover View Post
Last week I was at VIR for two days the air temp was 95 plus. My oil temp after a run was 275 is that too high? Should I have used 15/50 oil instead of 5/30. My water temp was about 195.
not sure about the oil temp (I'll check and see what mine is at today)...but the water temp is about right for stock. I'd stick with the recommended mobil 1 5w30. With a 160 t-stat, mine runs around 180-185 on a hot day, so you may want to consider that if you want to drop your temps.

2010-2SS/RS/LS3/IBM/RP6: ECS-Paxton Supercharger / American Racing Headers & Exhaust / PFADT Suspension / DSS 9" 4.10 Rear / FOR SALE!

Quote:
Originally Posted by Taglane View Post
Powerfreak is the only one who actually understood anything.
POWERFREAK is offline  
post #30 of 32 Old 05-21-2011, 07:31 AM
Junior Member
 
Join Date: Jan 2011
Posts: 50
 
Wow. Lot's of detailed information there. Don't know squat about engines but whatever they did according to this white paper definately worked.
Camaro.RS.2SS is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome