Camaro L99 Valve lifters problem - ModernCamaro.com - 5th Generation Camaro Enthusiasts
V8 Engine Discussion 6.2L LS3/L99 V8 | Exhaust | Ignition | Induction | Intakes

 
LinkBack Thread Tools
post #1 of 4 Old 05-10-2017, 03:10 AM Thread Starter
Newbie
 
Join Date: May 2017
Posts: 2
 
Camaro L99 Valve lifters problem

Hello dear, I would like to ask how to replace the bad valve lifter on the Camaro 2012 L99 8V. I have heard the tickle noise when engine run.. I heave recorded the voice for sure and check. I think it is some broken valve lifter.

You can check here on this link: https://www.dropbox.com/s/xig5haoxq6...amaro.m4a?dl=0

The sounds going ( when you looking on the car in front ) left side only - co-driver side..

I checked lot of forums and videos but nobody show or explain on the LS99 engine.
This ticking start 2 days ago acutally when was driving the car..

I bought this car year ago from USA, love this car.
Many thanks for help!
Jakub is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-22-2017, 10:18 AM
ユキヒョウ
 
Nancygrl's Avatar
 
Join Date: Jul 2011
Posts: 1,439
 
The lifters ticking in some of the L99 engines are a known problem because of the DOD (displacement on Demand). I know many people have done the LS3 conversion when this happens.

2019 1SS/1LE
Nancygrl is offline  
post #3 of 4 Old 06-22-2017, 06:04 PM
Premium Member
 
patriotpa's Avatar
 
Join Date: Aug 2008
Location: Pennsylvania
Posts: 6,220
  
Garage
Some lifter tick is normal. Get a dealer to take a look before you shell out for repairs you most likely don't need.

As far as a "known problem"? Doubtful. I'm @ 93K, drive hard and have ZERO issues.

James 1:25 Ordered from Faulkner Chevy #NKCF02 1100 5/8/9 2000, 3300 7/16/9 TPW 7/20,GOT MY (low) VIN! 4000 7/24/9 ,Picked up 8/7/9!!! Signed Litho #45. Car signed by FBodfather 2011. Service: Jennings Chevy in PA. We don't "drift", kiddies... we POWER SLIDE! MOTM/COTM Sept 2012 Pro Patria Vigilans.
Click the pic.. I don't tolerate fools.
patriotpa is online now  
 
post #4 of 4 Old 06-23-2017, 12:31 PM
ユキヒョウ
 
Nancygrl's Avatar
 
Join Date: Jul 2011
Posts: 1,439
 
Quote:
Originally Posted by patriotpa View Post
Some lifter tick is normal. Get a dealer to take a look before you shell out for repairs you most likely don't need.

As far as a "known problem"? Doubtful. I'm @ 93K, drive hard and have ZERO issues.
Then you're one of the lucky ones.

yes it is a known issue with the L99's. and other a host of other vehicles with AFM engines. There is even a TSB for the problem. I know of at least 6 people here in NC alone that have had to get the lifters changed out on one side or both, Camaro SS with L99 from 2010 thru 2014 model years. Latest TSB number is TSB #10-06-01-007D


Here is just one example of a post from another forum :

"The problem with AFM is with the lifters.

This is a known problem with a TSB. I had my lifters replaced under warranty with an improved design. If you were buying my car, you would get the receipt for the TSB work.

It's unclear when production transitioned to the improved lifter design. GM had this problem for years, but kept using the old lifters even after the TSB was issued. Apparently they continued until stocks were depleted. If you search this forum, you will find cars as late as 2013 still having the problem."

2019 1SS/1LE

Last edited by Nancygrl; 06-23-2017 at 01:30 PM.
Nancygrl is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the ModernCamaro.com - 5th Generation Camaro Enthusiasts forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome