Modern Camaro Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
First post, I saw a related topic, but it was regarding 2011 Camaro's:


My A/C was not cold at all. I checked the Relay's and switched 2 of them it started working. All of a sudden the temp outside was pumping through the vents and my car was fogging up ridiculously. The A/C won't stay on, sometimes it won't even turn on.

I had the compressor replaced by the dealership Sept 10' after dealing with AC belt noises for the first couple months that I owned the car.

I know that there is a recall for this with 2011's but since my compressor was replaced at the end of 10' is this going to cover the bulletin since the part is most likely a faulty 2011?
 

·
Registered
Joined
·
383 Posts
First post, I saw a related topic, but it was regarding 2011 Camaro's:


My A/C was not cold at all. I checked the Relay's and switched 2 of them it started working. All of a sudden the temp outside was pumping through the vents and my car was fogging up ridiculously. The A/C won't stay on, sometimes it won't even turn on.

I had the compressor replaced by the dealership Sept 10' after dealing with AC belt noises for the first couple months that I owned the car.

I know that there is a recall for this with 2011's but since my compressor was replaced at the end of 10' is this going to cover the bulletin since the part is most likely a faulty 2011?
Wow,

Truly sorry to hear about the A/C issues! I know that must be pretty irritating for you. I would be happy to search any recall information if you private message me your VIN and mileage. Have you also been to this dealership for this particular issue? If not, I'd like to schedule a visit for you! Message me when you get a chance.

Regards,

William R.
Chevrolet Customer Care
 

·
Registered
Joined
·
1,925 Posts
First post, I saw a related topic, but it was regarding 2011 Camaro's:


My A/C was not cold at all. I checked the Relay's and switched 2 of them it started working. All of a sudden the temp outside was pumping through the vents and my car was fogging up ridiculously. The A/C won't stay on, sometimes it won't even turn on.

I had the compressor replaced by the dealership Sept 10' after dealing with AC belt noises for the first couple months that I owned the car.

I know that there is a recall for this with 2011's but since my compressor was replaced at the end of 10' is this going to cover the bulletin since the part is most likely a faulty 2011?
You should ask them if they did the "re-programming recall" while they were replacing the compressor. The BCM needs to be reprogrammed on some models to keep the evap from freezing up which then shuts the system down completely until it thaws out (which will give you the crazy fogging symptom you mentioned)....
 
1 - 3 of 3 Posts
Top