Modern Camaro Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Hey guys,

I have noticed the AC compressor clicks on and then off after starting the engine on our SS. It only does this cold or after the engine has been off for a while.

The only climate button pushed is the blower fan speed.

Anyone else notice the compressor clicking on and then off after starting engine cold or after sitting for a while? Anyone maybe have an answer why?

Thanks
 

·
Premium Member
Joined
·
4,383 Posts
I have noticed mine does that as well, always has but I never really think about it. After 60k miles and five years I guess it's OK.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #3
I have noticed mine does that as well, always has but I never really think about it. After 60k miles and five years I guess it's OK.
Thanks for the reply.
I had not noticed this until the other day but sounds like your car is giving you good service.:thumbsup:
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
Anyone else want to post a reply if the AC Compressor clicks on and then off in your car when started cold? No buttons are pushed on the ac/heater control.

Service dept. does not have an answer.
 

·
Registered
Joined
·
4,590 Posts
I'm many days, the others days I usually am listening to the exhaust ... I'm trying to remember to check but out of town and rain keep the starts down. Hot engine? cold engine? does it either way?
 

·
Registered
Joined
·
71 Posts
Discussion Starter #7
I can't hear much exhaust on this L99. :lol:

The AC Compressor will kick on and then off only when car is cold or after sitting 6 or more hours.

Service manager so far has not been able to find out anything. I know it's not a big deal just like to find out why. Never had a car do this before. :confused:
 
1 - 7 of 7 Posts
Top