Modern Camaro Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
4,449 Posts
Discussion Starter · #1 ·
Just got my American Racing headers in the mail.

was curious to know if any of you guys got a check engine light for the rear O2 sensors and what you did to fix it besides getting a custom tune.

I gotta DiabloSport tuner and i'm having their tech support write me a custom tune to delete these trouble codes, one of the perks with buying their programmer.

i haven't installed them yet but anxious to see the results with my Magnaflow Comp Series Exhaust!!!

OHHH YEAAA NO MUFFLER! LOUD AND OBNOXIOUS!!!

headers1.jpg headers2.jpg headers5.jpg headers3.jpg headers4.jpg
 

·
Premium Member
2001 Camaro Z28
Joined
·
11,842 Posts
Does the system only use 2 of the O2 sensors?
If so, the other 2 can be programmed out of the computer.

EDIT: Looking closely at the pictures, it looks like there are bungs for all 4 O2 sensors, so you shouldn't set any codes for that. :)
 

·
Registered
Joined
·
4,449 Posts
Discussion Starter · #3 ·
yea but something with the front & rear O2's being a shorter distance apart and having to use an extension harness for the fronts throws off the calibration of the rears.

just what i've heard from people with different cars, but i won't know until its installed!
 

·
Banned
Joined
·
7,873 Posts
yea but something with the front & rear O2's being a shorter distance apart and having to use an extension harness for the fronts throws off the calibration of the rears.

just what i've heard from people with different cars, but i won't know until its installed!
I've heard the same thing...since you're having the tune done anyway, might as well just take care of it.
 

·
Registered
Joined
·
146 Posts
you will get a code eventually, for either of the cats efficiency, or for the front o2's insufficient switching time
 

·
Registered
Joined
·
6,759 Posts
actually the reason the check engine code comes on is because the o2 sensor is noticing that the air is moving through the exhaust at the same speed. the cat is normally there to slow down the movement. since the cat is gone, it moves through ratherquickly and throws the code. i was told the dealership can fix it, but you might as well take it and get a custom tune. for only 200-400 dollars, you can fix the check engine light, and get all of your parts workign together with freeing up some horse power. i need to make an appointment to get mine done. my light is on.
 

·
Registered
Joined
·
4,449 Posts
Discussion Starter · #9 ·
actually the reason the check engine code comes on is because the o2 sensor is noticing that the air is moving through the exhaust at the same speed. the cat is normally there to slow down the movement. since the cat is gone, it moves through ratherquickly and throws the code. i was told the dealership can fix it, but you might as well take it and get a custom tune. for only 200-400 dollars, you can fix the check engine light, and get all of your parts workign together with freeing up some horse power. i need to make an appointment to get mine done. my light is on.
true if you were running no cats. however i ordered the kit with high flow cats. do you think the light would still come on with higher flowing ones?

i also have a diablosport programmer, and their tech support will delete the rear O2 codes from the tune for free. FYI
 

·
Registered
Joined
·
25 Posts
Just got my American Racing headers in the mail.

was curious to know if any of you guys got a check engine light for the rear O2 sensors and what you did to fix it besides getting a custom tune.

I gotta DiabloSport tuner and i'm having their tech support write me a custom tune to delete these trouble codes, one of the perks with buying their programmer.

i haven't installed them yet but anxious to see the results with my Magnaflow Comp Series Exhaust!!!

OHHH YEAAA NO MUFFLER! LOUD AND OBNOXIOUS!!!

View attachment 4049 View attachment 4050 View attachment 4053 View attachment 4051 View attachment 4052
Generally, the cats are the problem. Codes pop from cat insufficiency issues. The cats run somewhat cooler, which causes these codes. You can easily program the codes out, but this may affect your GM warranty. You can delete the codes with MSDs Dashawk or similar code reader, but they will come back.

At one time the header companies offered SIMs that mimicked the voltage the ECM was looking for to effectively fool the test. You might check with the header company.

Jim Hall
 

·
Registered
Joined
·
6,759 Posts
true if you were running no cats. however i ordered the kit with high flow cats. do you think the light would still come on with higher flowing ones?

i also have a diablosport programmer, and their tech support will delete the rear O2 codes from the tune for free. FYI
shouldnt throw a code with cats on it.
 

·
Registered
Joined
·
6,759 Posts

·
Registered
Joined
·
4,449 Posts
Discussion Starter · #14 ·
Yep I spoke too soon! Got a code but lucky for my diablosport programmer. I had their tech support write me a custom tune to disable the O2 codes. None now!
 

·
Registered
Joined
·
6,759 Posts
yeah yeah yeah. i still got mine though......
 

·
Registered
Joined
·
144 Posts
I drove my car about 150 miles with a CAI, and ARH headers with no check engine lt. Had it tuned and 50 miles later check engine lt is on, the car also feels like its pulsating during normal driving. I'm not happy!! The tuner I brought it to is 45 miles from me. Gotta get back there this week.
 

·
Registered
Joined
·
1 Posts
Just got my American Racing headers in the mail.

was curious to know if any of you guys got a check engine light for the rear O2 sensors and what you did to fix it besides getting a custom tune.

I gotta DiabloSport tuner and i'm having their tech support write me a custom tune to delete these trouble codes, one of the perks with buying their programmer.

i haven't installed them yet but anxious to see the results with my Magnaflow Comp Series Exhaust!!!

OHHH YEAAA NO MUFFLER! LOUD AND OBNOXIOUS!!!

View attachment 4049 View attachment 4050 View attachment 4053 View attachment 4051 View attachment 4052
How long did it take for your headers to come in?
 
1 - 17 of 17 Posts
Top