Modern Camaro Forums banner

1 - 20 of 30 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hey guys, my car has been in the garage for about a month, and was just wondering why the battery would already be dead?

I went to go move it, as it was unlocked, and now the key is stuck in the ignition. Last winter, my dad kept the car in storage for 5 months and the battery was still good when I got it out.

Thanks, Dan.
 

·
Support MC & Troops
Joined
·
11,804 Posts

·
Bully Proof
Joined
·
7,086 Posts
I apologize for asking a stupid question...but did you leave a phone charger plugged in while it sat?

Because I had a problem with one of my vans discharging batteries and I had it in the shop 3 times and replaced the battery once with only 7000 miles on it. Now it has 10,000 miles on it and if it sat for more than a few days it was dead...and I mean really dead. I assumed the TV or the rear stereo or the game play unit was the culprit but it turned out it was my iphone charger (that I left plugged in all the time) and now my problem is solved.
 

·
Registered
Joined
·
1,925 Posts
Batteries don't take well to "cycling" and it will shorten their life each time it happens and if allowed to fully discharge can kill them completely (as in not come back to full charge). The car is supposed to shut down all draw on the battery after a time so as to protect it from fully discharging. So unless you have something going on like @Envy says, you most likely have a bad battery at this point. After it is replaced/diagnosed and you are going to continue to store the car, I would highly recommend a Battery Tender while in storage:

Automotive - Batterytender.com

Hell, I keep mine on one ANY time it is parked. I average 8 years on a battery. Even sold a bike with the original and fully functioning battery after 10 years!
 

·
Support MC & Troops
Joined
·
11,804 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Jump start it, see if that helps, take it to your dealer & see what they say,
it might just be a bad battery, it does happen :eek:
hope it gets figured out, keep us updated with what you find out :D
It's in the garage with the key stuck in the ignition so I'm going to have to buy a portable charger. What a pain in the ass.

I apologize for asking a stupid question...but did you leave a phone charger plugged in while it sat?

Because I had a problem with one of my vans discharging batteries and I had it in the shop 3 times and replaced the battery once with only 7000 miles on it. Now it has 10,000 miles on it and if it sat for more than a few days it was dead...and I mean really dead. I assumed the TV or the rear stereo or the game play unit was the culprit but it turned out it was my iphone charger (that I left plugged in all the time) and now my problem is solved.
If I can recall, if you have any kind of charging accessory in the outlets of our cars as opposed to older GM cars, cutting the ignition also cuts all power to the outlets.
 

·
Bully Proof
Joined
·
7,086 Posts
It's in the garage with the key stuck in the ignition so I'm going to have to buy a portable charger. What a pain in the ass.
Not that this will help with the charging...but the key can be removed without jump starting or charging the battery. If you remove the plug covering the hole below the ignition lock and insert a screwdriver into the opening as far as it will go...you should be able to remove the key from the ignition.

If I can recall, if you have any kind of charging accessory in the outlets of our cars as opposed to older GM cars, cutting the ignition also cuts all power to the outlets.
Not totally true. The battery can be drained if the key is left in the ACC/ACCESSORY or ON/RUN position with the engine off or if the Retained Accessory Power malfunctions.
 

·
Registered
Joined
·
2,495 Posts
With the new cars thats what happens, I was using the raido in my 09 traverse while cleaning it and the battery went dead. Key would not come out. As for leaving in the garage for a month and the battery going dead. I have to agree with Envy something is drawing power. one way to find out is hook up an AMP Meter and see if you have a current draw. You would have disconnect the negitave cable and hook up the AMP meeter between the cable and battery post. If you see the meter to to the discharge side you have a power drain. You will have to get it running first. I have had my Camaro since Jan 11 and have left it in the garage a couple of time for 30 days or more with out starting and the battery did not go bad. You could have a bad battery. I would take it to the dealer and have them check it out.
 

·
Support MC & Troops
Joined
·
11,804 Posts

·
Registered
Joined
·
1,925 Posts
Here's another thought. You could piss off the battery warranty and buy one of these and save yourself 40-ish pounds!

I just put 2 of these (smaller 8-cell versions) in my 2 bikes. F*in awesome!

I will def be buying one of these for my mine soon:
Batteries - Ballistic Performance Components
 

·
Registered
Joined
·
11 Posts
Discussion Starter #13
Alright guys, sorry for the late update, but here it is:

So, I jumped the car via the battery since it's in my garage. No biggie, right? Then everything went screwy. Car started, windows didn't work right, so I did the procedure to fix them. Next, compass registered - -. Interior dome light was pulsing. So I drove the car around for an hour and it was fine.

The cruise control didn't work, even when the button was pushed in. OnStar light isn't on in the mirror. Backup sensors didn't sound.

Parked the car. Attemped to re-start it, but it just went click click click.

I guess it's time for a new battery? Could it be a larger issue? Thanks.
 

·
Registered
Joined
·
1,925 Posts
Best way to know is to fully charge it with a charger then have it "load tested". You will know in about 5 mins for sure. Most auto parts stores can do this and also check the charging system while at it. But yeah, sounds like a battery....


Alright guys, sorry for the late update, but here it is:

So, I jumped the car via the battery since it's in my garage. No biggie, right? Then everything went screwy. Car started, windows didn't work right, so I did the procedure to fix them. Next, compass registered - -. Interior dome light was pulsing. So I drove the car around for an hour and it was fine.

The cruise control didn't work, even when the button was pushed in. OnStar light isn't on in the mirror. Backup sensors didn't sound.

Parked the car. Attemped to re-start it, but it just went click click click.

I guess it's time for a new battery? Could it be a larger issue? Thanks.
 

·
Registered
Joined
·
135 Posts
Hey guys, my car has been in the garage for about a month, and was just wondering why the battery would already be dead?

I went to go move it, as it was unlocked, and now the key is stuck in the ignition. Last winter, my dad kept the car in storage for 5 months and the battery was still good when I got it out.

Thanks, Dan.
Probably just left something on. Maybe a bad battery. Get it checked out and if its good i would say it was the first thing i said.
 

·
Registered
Joined
·
1,925 Posts
Acid everywhere after pulling the battery. Warranty issue?
Yup! Make sure you get some neutralizer in there to stop the acid eating away at **** and QUICK! Baking soda is the easiest. make a paste out of it with a little water, scrub it around in there with a brush for 10 mins and wipe down then rinse and dry...
 

·
Support MC & Troops
Joined
·
11,804 Posts

·
Registered
Joined
·
59 Posts
I had the same issue with mine about a month ago. The car only comes out of the garage when the weather is good and one Saturday morning after a month of sitting I got in and nothing. The key didn't stay in the ignition though. I tried jump starting and charging to no avail. Ended up taking the battery out and brought it to the dealer, it only had 6 volts so the dealer replaced it. Car is 30 months old with 5500+/- miles on it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #20
Took it to the dealership, and got it fixed under the 3 year/36,000 mile Delco warranty. All's well that ends well! They reset my computer too, that thing was a mess! :lol:
 
1 - 20 of 30 Posts
Top