Modern Camaro Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello dear, I would like to ask how to replace the bad valve lifter on the Camaro 2012 L99 8V. I have heard the tickle noise when engine run.. I heave recorded the voice for sure and check. I think it is some broken valve lifter.

You can check here on this link: https://www.dropbox.com/s/xig5haoxq6...amaro.m4a?dl=0

The sounds going ( when you looking on the car in front ) left side only - co-driver side..

I checked lot of forums and videos but nobody show or explain on the LS99 engine.
This ticking start 2 days ago acutally when was driving the car..

I bought this car year ago from USA, love this car.
Many thanks for help!:crying:
 

·
ユキヒョウ
Joined
·
1,442 Posts
The lifters ticking in some of the L99 engines are a known problem because of the DOD (displacement on Demand). I know many people have done the LS3 conversion when this happens.
 

·
Premium Member
Joined
·
6,255 Posts
Some lifter tick is normal. Get a dealer to take a look before you shell out for repairs you most likely don't need.

As far as a "known problem"? Doubtful. I'm @ 93K, drive hard and have ZERO issues.
 

·
ユキヒョウ
Joined
·
1,442 Posts
Some lifter tick is normal. Get a dealer to take a look before you shell out for repairs you most likely don't need.

As far as a "known problem"? Doubtful. I'm @ 93K, drive hard and have ZERO issues.
Then you're one of the lucky ones.

yes it is a known issue with the L99's. and other a host of other vehicles with AFM engines. There is even a TSB for the problem. I know of at least 6 people here in NC alone that have had to get the lifters changed out on one side or both, Camaro SS with L99 from 2010 thru 2014 model years. Latest TSB number is TSB #10-06-01-007D


Here is just one example of a post from another forum :

"The problem with AFM is with the lifters.

This is a known problem with a TSB. I had my lifters replaced under warranty with an improved design. If you were buying my car, you would get the receipt for the TSB work.

It's unclear when production transitioned to the improved lifter design. GM had this problem for years, but kept using the old lifters even after the TSB was issued. Apparently they continued until stocks were depleted. If you search this forum, you will find cars as late as 2013 still having the problem."
 

·
Registered
Joined
·
3 Posts
Hi, I have a 2010 L99 and have had a lighter ticking noise for at least about 3
Thousand miles. I also have a rough idle and check engine light now. The code is PO174. Do U think this code and the rough idle is because of a possible dead lifter? Any help would b much appreciated. Thanks
 

·
Premium Member
Joined
·
6,255 Posts
L99/LS3 lifters tick. No worries. P0174 is Fuel System Trim Lean Bank 2.
Check for vacuum leaks, esp. after the MAF. If you don't find any, get the dealer to have a look. It shouldn't be much to fix this.
 
1 - 8 of 8 Posts
Top