Modern Camaro Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
134 Posts
Discussion Starter #1
Just did my first oil change on the SS. 8 qts mobil 1 extended perf 5W30. Reset oil life and put it away. Just cranked it up to go grab some dinner and check engine light was on. Shut her down and taking her in tomorrow morning.

Anyone ever have this issue and might have a suggestion? Maybe disconnect battery for a minute? Manual says 8 qts so not like I overfilled it or anything.
 

·
Registered
Joined
·
16 Posts
It could be anything. Just take it to autozone and have them read the code to see what it is first before taking it to the dealership. It could be something as simple as a loose gas cap. Did you put the oil cap back on tight because if not that will trip a CEL also.

 

·
Registered
Joined
·
134 Posts
Discussion Starter #3 (Edited)
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?
 

·
Registered
Joined
·
16 Posts
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?
That's normal for the gauge 2 go up as u accelerate. Cel wouldn't go if it were to high but if it were 2 low it could trip it. Did u double check your oil cap also? If its loose it will let unmetered air in and trip the cel
 

·
Bully Proof
Joined
·
7,086 Posts
Thanks for the reply. Yea gas cap was first thing I checked. I'll try auto zone like you said. Just thought the timing was odd since I changed the oil the day before.

I did notice my oil pressure guage starts off at 30 but increases as I accelerate. I've read that this is normal though. Can high oil pressure maybe trip the CEL?
That's exactly how my V6's gauges read and is perfectly normal I believe.
 

·
See You On Course
Joined
·
3,867 Posts
Maybe the low pressure after the oil change caused the initial trip of the CEL, and once it comes up to full pressure, it just needs to be cleared? Just guessing. I changed my own oil, too, but never got the CEL.
 

·
Registered
Joined
·
134 Posts
Discussion Starter #7
I appreciate everyones response! Just went out and looked over everything and noticed that the CAI had slipped off the throttle body. Pretty sure that was what tripped it. The check engine light is still on, but I'm assuming that will go away after driving for a while. Just ran to McDonalds and back and it's still on..
 

·
Registered
Joined
·
16 Posts
I appreciate everyones response! Just went out and looked over everything and noticed that the CAI had slipped off the throttle body. Pretty sure that was what tripped it. The check engine light is still on, but I'm assuming that will go away after driving for a while. Just ran to McDonalds and back and it's still on..
That will set off your CEL with out a doubt give it about 20 to 50 miles and it will go off:thumbsup:
 

·
Registered
Joined
·
134 Posts
Discussion Starter #10

·
Registered
Joined
·
383 Posts
I appreciate everyones response! Just went out and looked over everything and noticed that the CAI had slipped off the throttle body. Pretty sure that was what tripped it. The check engine light is still on, but I'm assuming that will go away after driving for a while. Just ran to McDonalds and back and it's still on..
45thAnniversary2SS,

Sounds like you have this covered. But, you can always take it the dealer just to be sure. If you continue to have issues please feel free to contact me directly.

Thanks!
Ashley,
Chevy Customer Assistance
 

·
Registered
Joined
·
134 Posts
Discussion Starter #12
Thanks Ashley. I called the dealership and they gold me that would certainly trigger the CEL and that since I secured the CAI the light would go out after about 20 miles.

It went out last night so I'm all set. Everyones responses are greatly appreciated.
 

·
Registered
Joined
·
1,107 Posts
There really is nothing that you could of done during an oil change to set off that light. It's prolly something else.
 

·
Registered
Joined
·
134 Posts
Discussion Starter #14
There really is nothing that you could of done during an oil change to set off that light. It's prolly something else.
You're right. However, I think I may have bumped the CAI off the Throttle Body during the oil change. It was getting dark out and I was being distracted.
 
1 - 15 of 15 Posts
Top