Modern Camaro Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3,055 Posts
Discussion Starter · #1 ·
Ok, on my 2002 Camaro, I don't drive it all that often. I have the Optima red top, about 2 months old. Clean connections (still look new). To keep the battery topped up, I got a Battery Tender Plus, so it's only a couple of months old as well. Up until a few days ago, it's been working great.

So, the other day, I unplug charger, then take the car out for a drive. When I get back, I plug the charger back up. This is where things get weird.

Red and green lights on charger, says red should come on steady and green may be off for a little bit, then it should come on indicating full charge. Red flashing means it isn't hooked up properly according to the trouble shooting guide.

Now, no matter if it's hooked up or not, when I plug it into the wall, the red light flashes and the green light is always steady on. Always. No matter what as long as AC power is applied.

I've checked the in line fuse, it's good. I've checked voltage out put at 22 volts. I've checked voltage across battery when hooked up, >14.5 volts.

I'm worried something's wrong, but this isn't covered in any troubleshooting guide.

Any ideas? Anyone else have this issue? TIA.
 

·
Registered
Joined
·
1,534 Posts
Get another battery tender.. if it works then you know you have a bad one, if it doesnt work take it back to the store and get your money back.
 

·
Registered
Joined
·
3,055 Posts
Discussion Starter · #4 ·
Where were you 5 years ago when I asked the question?? :)
 

·
Registered
Joined
·
1,534 Posts
lol.. sorry, couldn't resist.. that was my poor man's fix it solution..
 

·
Premium Member
Joined
·
4,397 Posts
Well, not worth worring about it cause the fix cost more than a new on at "Harbor Freight" for about 10 bucks.
 

·
Registered
Joined
·
3,055 Posts
Discussion Starter · #7 ·
My point was I asked the question in October....2008!
 

·
Premium Member
Joined
·
4,397 Posts
:eek: Sorry brother I did not notice how old the post was. I hope you found an answer to your problem.:thumbsup:
 

·
Registered
Joined
·
3,055 Posts
Discussion Starter · #9 ·
I did replace the battery tender. But the reason the thread got necromanced was because of Beremenne (now banned) idiot spammer decided to resurrect it for some random reason.

Funny, the original post was 8 days before my dog "Rocket" was born...and he just recently celebrated his 5th birthday!!
 

·
Premium Member
Joined
·
4,397 Posts
Well then "Happy Birthday Rocket"!!!:lol:
 
1 - 10 of 10 Posts
Top