Modern Camaro Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
This car is going to be the death of me. Runs fine until it gets up to temp. Then, it starts to misfire. Fuel pressure was low, around 31, so replaced the regulator and the fuel pump. Pressure is close to 40, but the misfire continues. Could this be a bad injector? Something in the throotle body? Any help would be greatly appreciated.
 

·
Registered
Joined
·
1,107 Posts
Prolly the opti-spark. But it's hard to tell without seeing the car.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Hoping it's not the optispark. Put a MSD in a year ago. Keep getting a cylinder 1 misfire or a 0300 multi misfire code.
 

·
Registered
Joined
·
1,107 Posts
Is the ses light flashing?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
when the engine gets up to temperature, I get a0300 dtc (multiple misfire) or a 0301 (cylinder 1 misfire). Read somewhere this can be caused by a leaky fuel injector. I still think a wire is getting hot and arcing somewhere, but all the spark wires are good and other electrical looks fine. the ses does flash when it gives the 0301 code.
 

·
Registered
Joined
·
1,107 Posts
When I had a 97 I had the 0300 code and it turned out to be the opti. The car would start to misfire bad if i got on it. If you only had the cyl 1 issue it might just be that plug or wire but I'm still leaning towards the opti. Check under the water pump and look at that drain hole under the water pump to see if it leaking on the opti.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #8
thanks, the optispark was the main issue. Got it out and opened it up and had a bunch of corrosion in it. waiting on some moolah for a new cap and rotor. Does anyone sell replacement optical triggers for a MSD 83811, or am I SOL?
 

·
Registered
Joined
·
1,107 Posts
Replace the water pump while you have it apart.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #10
Yeah, i got a new one waiting. New cap and rotor coming in today from Summit Racing. Fingers crossed.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #11 (Edited)
New cap and rotor did the trick. Got it all put back together thursday. No more misfire. Still wont pass emissions, OBD II hasn't completed full diagnostic cycle. But, getting there!!!
 
1 - 11 of 11 Posts
Top