Modern Camaro Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Hi all,

I'm having a strange issue, I have a 2010 ss 6speed manual. when driving all is normal, shifting is ok, when stopping at an intersection or light as long as clutch is depressed the idle is normal. foot off clutch and not moving all is normal.
But if the car is moving at any speed and I take out of gear and coast in neutral , when I take foot off clutch the idle races up to around 2000-3000 rpms and will stay there until I step on clutch again.

Any ideas what could be issue???

Thanks Jeff
 

·
Registered
Joined
·
1,690 Posts
Hey there, fellow NJ resident!! LOL!! Any updates to this issue?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #3
hey chapel, whats going on?

I had a bbk throttle body installed for some time now and it started giving me reduced engine power , so I had bought a new complete throttle body to use the new throttle actuator on the bbk thinking that maybe my old one went bad, this is what led into the other problem that I had listed above. that was the just the short version of the whole issue.

with the bbk , when it was working properly, I had a perfect idle and it shifted fine. after the problem started I called summit racing cause that's where I bought the bbk from, and they had no help for me , his exact words were "things go bad and break " not the answer I was looking for. so after being more pissed off. I installed the new stock throttle body and that's when the high idle issues had started.

but I'm glad to say as of now October 9th, the computer must have adjusted everything and the problem seems to gone away, hopefully forever.

thanks for asking anyway.
 

·
Registered
Joined
·
1 Posts
if it comes back, it is the throttle actuator that is causing it, take it to the dealer and have them do a throttle relearn
 
1 - 4 of 4 Posts
Top