Modern Camaro Forums banner

1 - 20 of 38 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
I just bought a 1988 gta for 600$

Im syked! It needs a muffler, and the australian 9 bolt rear end in it is junked, But it runs awesome!


its got the 5.7/700r4/Gold rims/black interior

and i just happen to have a nice parts car outside :D for the rear end.

Will post pics when i get it trailered here
 

·
Premium Member
Joined
·
2,717 Posts
Nice! I got a friend who is trying to sell his. 600$ sounds like a **** good deal. Especially if it's major issue is rear end problems.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #6
Yeah honestly, i had to snatch it once i saw it ran good and was in decent body shape.


Well see after i get the rear end in and take it to work and look at it in fine detail well see what i find :/

Im thinking just Maint. Based on how the car looked

Probly do a Delco/mobil 1 oil change, Rapid fire plugs, wires, cap/rotor, tranny service. and ill see where im at,
probly gonna have to flush the coolant 2, Forchanutely Nissan Coolant Is RLY Good stuff( Ive seen it come out perfectly clean at 90k, Never changed) that says something about DEX cool :p.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #7
just got the car, rear end looks/works ok but the kid left the cover of it



its a 9 bolt Gm rear... needle in a haystack for a cover.. any ideas? i need to drive it by monday pref
 

·
Moderator
Joined
·
2,774 Posts
great find! Wondering where you bought it? I saw one for sale a while ago somewhere in the Metro west area just wondering if it was the one I saw...

again good luck with it. One of my fav looks of the T/A and IMO the best look of the 3rd gen. Poncho
 

·
Registered
Joined
·
154 Posts
Discussion Starter #10
just found after more research under the car it has a 10 bolt


i took the cover i had and put it on, then threw some fluid in it... odd noises for sure but drives nice.


Now i need to replace the rear brake hose/line and ill be good
 

·
Registered
Joined
·
154 Posts
Discussion Starter #11 (Edited)
haha sorry no pics to speak of yet

my cell phone cant send them :/


So on go's the process.. the rear end whines.. pinion bearing

also rear calipers are seized, But have new pads, the front rotors/bearings/seals/pads were put on less then a month before i got it * aprox*
I flushed the tranny with 18 quarts, Brown fluid- to bright pink and its still shifting fine * hoping it wont slip its been a week*
Motor Runs GREAT! Has a small stumble once and a while but ill track it down, I believe its been rebuilt because of the 45 psi oil pressure at 600~ rpm ( high flow like everyone do's * stupidly* And there was also so wear on the Old dist. gear.

I put a distributor in from my other car ( reshimmed, bronze gear, new ig coil, new pickup coil, new rotor, new cap, new wires)
Still has the slightest stumble once and a while, checked the plugs ... there bosch POS's.

Project for tomorow- Ac Delco Rapid Fires
Lucas Additive/gear oil/LSD additive To rear end

And Hopefully at some point ill be able to flush the coolant
 

·
Registered
Joined
·
10,420 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #15
bad news, upon further inspection with the cover of, metal fragments were in the front of the diff and attached to the cover plate



so i said **** it, well see how long it lasts, lol and filled the fluid etc


Also- Put the rapidfires in.. runs about the same So maybe seafoam is a good idea? Ive never used it before

Also the IAC is starting to take a dump on me, so i got to fix that 2 :/
 

·
Registered
Joined
·
154 Posts
Discussion Starter #17
Update


Rebuilt the throttle body with all new gaskets, New IAC Motor

Reset Iac, and readjusted tps.

Idle is strong @ 700 Rpm now, thing that irritates me is in P it go's to 1100

Probly a tiny vacuum leak somewhere, Im going to replace all the lines soon enough anyway.

Found out why all of a sudden i hear a ticking noise/bad gas mileage

No bolt in the rear of the exhaust manifold ~leak right above the ****ing 02~ so its running PIG rich...(also explains the tiny slightest miss i have most likely) Going to inspect it further to find out if the old bolt was snapped in there.. that would blow.

The trans has a major leak at the tailshaft seal, since i had to throw a new driveshaft in, Should be getting taken care of soon. I only checked because the tranny slipped on me and it was down a few quarts.

I threw some lucas Additive in * that **** is like black magic* And hoping itll cure any possible future transmission death for now.-fluid is still red-

Still havent gotten pics, lol and havent gotten to take care of some of the rust that i HAVE to get primered before winter or else we all know what will happen
 

·
Registered
Joined
·
154 Posts
Discussion Starter #19
I wish i could i have like 10 on my cell phone but it wont let me send them, can only send txt which is gay lol


Once i get the cable to hook it up you got it :p
 
1 - 20 of 38 Posts
Top