Modern Camaro Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
my 94 camaro rs is makin a clickin noise. i put flowmasters on it and could only get 1 of the 2 bolts back into the cat. it runs fine but i know i have an exaust leak. i put some radiator stop leak in it and the next day the **** thing was makin a clickin noise. it started that morning when i first started it but stoped w/in 15 seconds. so i didnt think anything of it. i drove around all day. and that night when i was goin to run to the store, there was the clickin. i waited and it didnt stop. so i put some sea foam in my oil( thinkin 1 of my valves was stickin) didnt work.
what could be wrong?
i live in plano off 121 and coit, and if someone could come by and look at it and mayb tell me whats wrong or something that would be great.
 

·
Banned
Joined
·
4,153 Posts
I'm sure the o-ring on the cat isn't seated right, therefor causing an exhaust leak. They almost always sound like engine ticking. It's not a big deal. Just annoying.
 

·
Premium Member
Joined
·
2,717 Posts
You put radiator stop leak in because of an exhaust leak? Or was there something wrong with the cooling systome to warrant that. Like the two above said the exhaust leak is the cause of your tick.
 

·
Banned
Joined
·
7,873 Posts
OK, don't laugh, but you DID put the radiator stop leak in your radiator...right?

I saw a thread on a mazda miata:lol: board where a "smart" miata owner put radiator stop leak in his engine.:BangHead:


:hello:but anyway, yes, it sounds like an exhaust leak.
 
1 - 7 of 7 Posts
Top