Modern Camaro Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
I ran my 2014 ss up to about 5800 rpm and got an oil smell in the car.I checked the engine for leaks but there were none.Any ideas????:
 

·
Registered
Joined
·
96 Posts
Probably built up carbon from babying it if it was just a momentary smell. If it is continuous, much bigger problem. Let me know any other symptoms your car is displaying.
 

·
Registered
Joined
·
1,690 Posts
Are you sure it was oil? If you were really moving then it could have been the catalytic converter. They put out a fume when you drive aggressively.
 

·
Registered
Joined
·
1,465 Posts
Is it a burning smell?????? I ask because I notice a smell every now and then...when as Chapel put it been "really moving."
 

·
Registered
Joined
·
1,690 Posts
I'm thinking it was just the cats. Especially if he was at 5800 rpms and even more so if he stayed at the rpm for some time. If any fluids had been leaking, then he would have also had some smoke. Or there would have been some visible evidence of fluid leak. My Mustang and F150 both put out an odor when I'm on the gas. And my SS used to do that back when I had the stock cats and the HF cats. Its just something that happens.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
IT WAS A OIL SMELL, MAY BE BURNED,I WAS ON IT ONLY FOR A SHORT BURST.I DON'T REALLY BABY IT.I WILL TAKE IT OUT WHIN THE WEATHER CLEARS UP AND REALLY BLOW IT OUT AND SEE WHAT HAPPENS.
 

·
Registered
Joined
·
1,465 Posts
Thanks for the explanation, Chapel.....makes me feel better. My girl is still ALL good
 

·
Registered
Joined
·
275 Posts
or the clutch wasn't engaged fully and you were burning it a little.
 
1 - 8 of 8 Posts
Top